Adapter service unable to look up tables

i am using 6.5,oracle 9i.The problem is whenever i want to create an adapter service i am not able to see the tables in it even though the connection status is enable.Is the problem with 9i or with 6.5
Thanks & Regards

I’ve seen this happen when the user ID used on the adapter connection does not have sufficient permissions on the database to browse Oracle objects. Your DBA can help you either grant additional permissions to the user or can create an Oracle user with the required permissions.


Thanks for your repply,I tried in my local system by using scott and tiger as username and password.The sql commands are working properly
but i am not able to see the tables.


Stupid question probably, but have you selected the right schema in the “table” tab of the adapter (in 6.0.1 at least - no xperience with 6.5). Perhaps the level of selection here could be indicative for your problem: if you can see the different schema’s, then at least you know you’re accessing the DB. Howbout trying <current_schema>?
Have you disable - enabled your connection yet? Anything in the logs?

Anyway, HTH


I tried everything.It’s not showing the schema’s.It’s only showing the currrent schema.when i clicked(+) to expand ,it’s showing nothing.
Actually we expect the users.By the way the connection is enabled.