Adapter notification does not fill the destination Queue


I have a problem with one of my adapter notification. It fills correctly the buffer table when updating records in source table but the
destination queue is empty and buffer table keeps the records. So the trigger connected to the queue does not triggers the destionation flow and eveything is blocked.

I checked everything i could to determine what’s wrong but i can’t find what is happening :

  • The polling notification is enabled
  • All triggers are enabled
  • Nothing appears in server logs
  • The adapter notification is using JMS provider with an active JMS connection

Is there something i am missing ?

Is this issue happening in the DEV environment or similar setup working fine in any other env’s?

Basically with out having any kind of stacktrace in the logs becomes tough to troubleshoot. So if you can bump up the logging sub-system and monitor the logs?

But Most likely the JDBC notification setup issue or some thing sort of… Can you try rebuild the notification for the update event (making sure all the related artifacts loaded correctly wrt broker/JMS configuration) and see if that resolves.


Hello !

Yes it is possible to raise verbosity of logs we are in a DEV environment. We just don’t really know how to make it can you share more details about that ?

About rebuilding the notification we already tried that. What are the related artifcats you are talking about ? I can tell you that all scheduled tasks, buffer table … are there when we create the adapter.

Before your answer i noticed some ACL misconfiguration on the queue that I created (only i had access to push on the queue) but this does not seem to fix the issue.


I found how to raise logs verbosity in both Integration Server and Universal Messaging but i can’t find any issue after launching an update.
Nothing appears in logs concerning the queue that is supposed to be filled.

I have tested the modification of ACL properties of the queue but it does not seem to do anything on that particular problem.
Maybe it was part of the solution but not the whole solution.

The conclusion is that the adapter notification is correctly called (according to logs) but the corresponding queue is not filled with the JMS message (nothing appears in UM logs here and the snoop function on the queue does not detect any message).

I tried to delete and remake all objects that are concerned (adapter notification, JMS Connection, Queue and triggers) but the problem persists.


The error is on the source table side.
So everything is ok on softwareAG side
Thank you for your help

Hi Joris,

were you selecting complete table for the notification and the table has LOB-columns (does not matter if BLOB or CLOB)?

These columns should be omitted during polling and then being selected afterwards after the notification triggered the implementation service.

When omitting the LOBs during polling this also relates to throughput performance and storage required on the messaging system.