MSMQ adapter listner issuse

Hi Users,
I am trying to get a message from queue…When i enable listner notification i am getting this error…Can any body faced this kind of issue before…

ART.115.3253] Adapter Runtime (Listener): Listener MSMQ.Adapterservices.AdapterListners:Get_Listner did not process notification.

Waiting for positive response…


Did you enable the 0660 MSMQ adapter log, maybe this will give you more info about the problem.

If you do not have an listenerNotification associated with you listener or if the notification is not enabled you will see this problem.

Thanks for the reply…I solved this problem…Now i had some other things.

  1. While trying to get the message from queue by using synchronus listener notification.
    The message is getting deleted from queue but i am not getting data from request doc.i am not getting what is the problem
    the same thing i tried by asynchronus notification at that time able to get the data…
    Waiting for positive response.

You have to use ‘Transactional’ type of connection so that you don’t loose message when the processing service fails for whatever reason… Also, ‘transactional connection’ can only be applied to ‘transactional queues’. refer documentation…


Hi Senthil,
Exactly i done in the same way what u r expecting.even i am getting the above mentioned problem…is there any other chance.

How do you process the file in your notification, do you publish to broker or invoke a service? Is the request doc empty or do you not have any data in your object Body?


Hi holmbergjohan,
For Asynchronus notification i published that doc to broker…Triggerd doc from broker and invoked sub service with that published doc…here i was able to get the message body.

For synchronus notification I directly invoked the service…here i was unable to get the message…

Hope for the solution…