ADAIOR Internal Error on ADAMUP utility


We have a lone application still running Adabas 4.1.1 on a DEC/VAX (yes, DEC/VAX…) If anyone might be able to help with this issue, I would be most appreciative.

I am experiencing a problem with the ADAMUP utility (“internal error in the I/O module”). The problem appears to be confined to a single database, and thus far to only the ADAMUP utility. (Thankfully, ADABCK RESTORE worked!)

ADAMUP works as normal on other databases, but any file I have tried on the impacted database receives the same error:

%ADAMUP-I-STARTED, 10-MAY-2010 16:20:28, Version 4.1.1, (OpenVMS VAX)
ADAMUP dbid=1
%ADAMUP-I-NUCACTL, ADABAS nucleus active on local node
ADAMUP update=17
%ADAMUP-F-IORERR, ADAIOR internal error 39/0A
%ADAMUP-I-CALLDUMP, requesting process dump creation
%ADAMUP-I-IOCNT, 1 IOs on dataset MUPDTA
%ADAMUP-I-IOCNT, 3 IOs on dataset ASSO
%ADAMUP-I-IOCNT, 0 IOs on dataset DATA
%ADAMUP-I-IOCNT, 0 IOs on dataset TEMP
%ADAMUP-I-IOCNT, 0 IOs on dataset SORT
%ADAMUP-I-TERMINATED, 10-MAY-2010 16:20:30, used cpu-time : 00:00:00.10
ADABAS job terminated at 10-MAY-2010 16:20:30.36

There is nothing written to the MUPERR file, nor is a dump created. I tried
shutting down the database and renaming the ADABAS.001 file, suspecting it may be corrupted. This did not resolve the problem. I also tried using data that was successfully ADAMUPed on another database; also unsuccessful. I am at a loss…

The Adabas help utility says: “Action: Contact your nearest support centre.” Ouch! Software AG, of course, dropped support for the VAX in 2001. Perhaps this will help the client to see the urgency in moving off the outdated hardware, software, and operating system, but in the meantime, I would be most grateful for any help someone might be able to offer.

Thanks so much,
Janet Christman

State of New Jersey

Adabas 4.1.1
OpenVMS 7.1

This problem has been resolved - we had a corrupt TEMP dataset.