ADAULD Problem

[size=“18”][color=“darkred”]Hello Forum:

I am trying to copy data from an Ababas File on Unix to an Ababas File on Win XP.

This is what I plan to do:

  1. Make a backup using ADABCK (already done)
  2. Unload the one file (ADAULD) using backup_copy
    backup_copy is a complete offline backup of DB101 (130 Files)
  3. Decompress the file (ADADCU)
  4. Define the new file in Adabas XP
  5. Load the file (ADAMUP) into Adabas XP using existing FDT

Step 1 executed successfully.
Step 2 crashed with the following ADAULD Error Codes.

%ADAULD-F-IOI31, op 5, rc 31 (Invalid RABN)
%ADAULD-F-IOIS1, typ 3, rabn 1, flag 0000000000000000

What is IOI31, op 5, rc 31 (Invalid RABN)
IOIS1, typ 3, rabn 1, flag 0000000000000000

and where can I find an explanation to this error message.

Arif [/color][/size]

$ export ULD001=ADABCK_DB101_100507_ULD001
$ export ULDDTA=ADABCK_DB101_100507_ULDDTA
$ export ULD001=ADABCK_DB101_100507_231700
$ export TEMP1=TEMP1.txt
$ adauld
%ADAULD-I-STARTED, 17-MAY-2010 15:41:11, Version (Solaris 64Bit)
adauld: backup_copy=101,file=41
adauld: ^D
%ADAULD-F-IOI31, op 5, rc 31 (Invalid RABN)
%ADAULD-F-IOIS1, typ 3, rabn 1, flag 0000000000000000
%ADAULD-I-IOCNT, 1 IOs on dataset ULDDTA
%ADAULD-I-IOCNT, 1 IOs on dataset ULDDVT
%ADAULD-I-IOCNT, 9 IOs on dataset ULD001
%ADAULD-I-ABORTED, 17-MAY-2010 15:41:37, elapsed time: 00:00:26
$ export BCK001=ADABCK_DB101_100507_231700
$ adabck
%ADABCK-I-STARTED, 17-MAY-2010 15:54:41, Version (Solaris 64Bit)
adabck: db=101
%ADABCK-I-DBOFF, database 101 accessed offline
adabck: read_check
%ADABCK-I-BKCHSUC, backup save set successfully checked
%ADABCK-I-IOCNT, 40 IOs on dataset ASSO
%ADABCK-I-IOCNT, 12732 IOs on dataset BCK001
%ADABCK-I-TERMINATED, 17-MAY-2010 15:55:00, elapsed time: 00:00:19

I can’t find this error message even in my oldest Adabas-Documentation (Version 5.1.7). Sorry.

But let me do a wild guess: You are on a SPARC-Processor on Unix-Side and on an Intel/AMD-Processor on Windows-Side. Sparc is big endian and Intel little endian…

Maybe setting the byte order (ADADCU-Parameter TARGET_ARCHITECTURE) helps. Please see your documentation for more details.

Now I see that you do the ADAULD on Solaris-Side. Then the different endianess is probably not the source of error…


SAG support tells me that backup_copy will not work with this version for some reason. They suggested that I try to ADAULD directlly from the DB.

Will let you know if that works,

thanks for you reply,


I tried direct unloading from the database and it worked fine - thanks.
However when I try to load the file onto the new DB I get error in ADAMUP.

ADAULD From DB201 on Solaris (successful)

$ adauld
%ADAULD-I-STARTED, 22-MAY-2010 12:02:18, Version (Solaris 64Bit)
adauld: db=201
%ADAULD-I-NACTL, ADABAS nucleus active on local node
adauld: file=53
adauld: ^D

Descriptor summary:

Descriptor AA : 216 bytes, 24 occ
Descriptor AQ : 344 bytes, 43 occ
Descriptor AO : 360 bytes, 24 occ
Descriptor AX : 602 bytes, 43 occ

%ADAULD-I-ULDREC, file 53, 67 records unloaded

%ADAULD-I-IOCNT, 1 IOs on dataset DATA
%ADAULD-I-IOCNT, 1 IOs on dataset ASSO
%ADAULD-I-IOCNT, 3 IOs on dataset ULDDTA
%ADAULD-I-IOCNT, 2 IOs on dataset ULDDVT
%ADAULD-I-TERMINATED, 22-MAY-2010 12:02:58, elapsed time: 00:00:40
$ ls -F
ADABCK_DB101_100507_231700 ADABCK_DB201_051710_231700
ADABCK_DB201_050510_231700 ADAULD_DB201_ULDDTA_F053
ADABCK_DB201_050610_231700 ADAULD_DB201_ULDDVT_F053
ADABCK_DB201_050710_231700 DCUOUT_053.txt

ADAMUP on Win XP using output from ADAULD (OPNERR and ILLSUM errors)

%ADAMUP-I-STARTED, 23-MAY-2010 17:22:20, Version (Windows XP)
%ADAMUP-I-DBOFF, database 201 accessed offline
%ADAMUP-F-OPNERR, Dataset MUPDTA, file F:\File Transfer\Migrate\ADAULD\ADAULD_DB201_ULDDTA-F053 could not be opened
%ADAMUP-F-ILLSUB, illegal subsequent UTIDTA detected, present 256, expected 1
%ADAMUP-I-DSDONE, data storage completed
%ADAMUP-I-NOCHNG, nothing changed
%ADAMUP-I-IOCNT, 0 IOs on dataset MUPDTA
%ADAMUP-I-IOCNT, 4 IOs on dataset WORK
%ADAMUP-I-IOCNT, 8 IOs on dataset ASSO
%ADAMUP-I-ABORTED, 23-MAY-2010 17:22:21, elapsed time: 00:00:01**

PS. What is this Mesg saying?
Can you direct me where to look for errors - not present in the Doc CD.


Hi Arif,

I don’t see any mention of the decompress/compress steps in your last post. They still need to be done and don’t forget to specify the target or source architecture to cater for the architecture difference.


Graeme Lane