ADADEF utility ERROR-137

I’m getting the error message below when I’m trying to define a database having ASSOSIZE of 120168 cylinder. ASSODEV is 8393.
Is there a way to pass this limit or do I have to understand that Adabas has some size restrictions on ASSO?

A D A D E F: Error occurred during execution:

ERROR-137, ASSOSIZE too large

       The size must not exceed 16777215 blocks. 
       Correct the error and rerun the job. 

Best regards.

From the Adabas DBA Reference/Tasks Manual, Database Maintenance Tasks, Database Space Management, Relative Adabas Block Number:

So in your case, where you need 21,630,240 Asso blocks, RABNSIZE=4 is needed in your ADADEF job.

Thank you for your help… it worked :slight_smile:

Hi again,
as I told you before; using RABNSIZE=4 in define job worked. But,
I’m now trying to restore data from ADASAV offline backup which I took before this database enlargement operation.
The restore statement is like “ADASAV RESTORE FMOVE=121”.
And the ERROR code it gets is as below: :cry:
ERROR-169, Incompatible RABN sizes

       An attempt is made to restore one or more files from 
       a database with 3-BYTE RABN's into a database with   
       4-BYTE RABN's.                                       
       The requested function cannot be performed.          

Do you have any idea about a solution?
Looking forward from hearing you.
Best regards.

To copy/move a file from a database with RABNSIZE = 3 to a database with RABNSIZE = 4 you could unload the source file (ADAULD) and load it into the target database (ADALOD).

So, it’s not possible to load by ADASAV :frowning: Unfortunately all our backups are taken by ADASAV.
In every restore case; to restore them first into a db defined with rabnsize=3, then unload data and finally load to target db won’t be so efficient I think.

Anyway, thank you for your kindly response…