Accessing a Document Through Flow and WS


Below is a dummied down version of a problem which I am encountering. I am wondering if this is a bug, or if I am doing something wrong.

I have two document types. The first one is RequestDoc and contains a single string field (named String). The second one is called RequestDocument and contains a document reference to request doc.

I have a flow service which takes as input a document reference to RequestDocument. This flow service has two debug statements both with variable substitution enabled. The content is as follows

  1. This will only print out correctly when the flow is called directly: %RequestDocument/String%
  2. This will only print out correctly when the flow is called by a Web Service: %String%

When I execute this flow directly only the first statement is printed out. When I create a web service which calls this flow only the second one prints out.

This causes a great deal of heart-ache when it comes to mapping fields within this flow. Basically I can not do any mapping using the regular interface - I need to use variable substitution and now this flow will not be able to be called by other flows.

I have attached a sample package (in zip format) which illustrates this behaviour. You will need to re-generate the WSDL from the flow service (Main) or update it accordingly.

Thanks for any insight. (15.4 KB)


The only problem I see in your package is the input to the webservice connector, It should be a document reference of instead of the inputs accordingly and test it. I tested the main service with by creating a new connector, it works as expected.


Thank you for your reply Pradeep,

I am confused. The input to the Main flow is a RequestDocument (which consists only of a RequestDoc node). Which is why the connector was generated with that input via developer.

I tried to change the connector to accept a document reference of:

However I got an error when I tried to run the connector saying /RequestDocument was absent (as expected).

BTW I am using WM version 7.1