access denied while invoking provider wsd service from soap ui (resolved)

hi all,

we are using wm96 (without any fixes)

  1. implemented provider wsd (no changes made to wsd’s permissions, no changes made to the wsd-> service’s permissions)
  2. while triggering the provider wsd’s service from soap ui, we are issued below error

User “local/Default” does not have permissions to invoke service

[ISS.0088.9164] Access to WSDescriptor :wsservice denied.
Caused by: com.wm.app.b2b.server.AccessException: [ISS.0088.9164] Access to WSDescriptor :wsservice denied.

any help is appreciated

thanks and regards
ajay kumar kasam

Its normal. Provide the required access through ACL’s.

Hi Ajay,

You can change the Execute ACL of the provider WS to Anonymous from Default or alternately you van pass credentials from soap ui operation properties.

Thanks
Baharul Islam

sorry, here is the important update

in the scenario i described below

  1. we get proper response on soap ui
  2. but the we see error log

User “local/Default” does not have permissions to invoke service

[ISS.0088.9164] Access to WSDescriptor :wsservice denied.
Caused by: com.wm.app.b2b.server.AccessException: [ISS.0088.9164] Access to WSDescriptor :wsservice denied.

Ajay – Please go through below one,

https://empower.softwareag.com/sl24sec/SecuredServices/KCFullTextASP/viewing/view.asp?KEY=114702-7561944&DSN=PIVOTAL&DST=TCD&HL=1&QUERY=com.wm.app.b2b.server.AccessException:|[ISS.0088.9164]&SessionID=708994354

Thanks,

Thank you “MR as173d”

You exactly resolved my issue.

The issue is genuine, because SOAP UI (WS client) is sending two HTTP request, soap ui (unless we explicitly state in preferences) won’t include user credentials in the first http request. For this reason, IS logs access denied for the first http request without user credentials.

Thank you

Very Glad to hear it’s resolved :smiley:

Happy to help, glad to hear issue gone away :slight_smile:

Thanks,

the issue is not gone. but we are now clear that its all good and ok behavior in IS to show the access denied log.

the actual problem is with ws client, in my case it was soap ui. i fixed soap ui. no fix in IS.

Happy to help, glad to hear issue gone away :slight_smile:

Thanks,

Okay, nops Ajay, Identifying issue is half win. We can win the full game once they( wc client ) come back.

Thanks,

Conclusion:

To fix this issue with SOAP UI. On SOAP UI go to file-> preferences -> HTTP settings -> "check" Authenticate Preemptively

resolved

Ajay – Thanks for your update, please share resolution steps you followed which will be useful to others.

Thanks,

Yes please do so which of the following you have used the path for the resolution :smiley:

HTH,
RMG