Access denied for user jna96864 on port 5556 -> 'soap/rpc' from 159.68.3.36.

Hi Guys, I’m trying to execute a portlet app and getting this error.
Access denied for user jna96864 on port 5556 -> ‘soap/rpc’ from 159.68.3.36.

IS port: 5556
MWS port : 8585

Settings in server.cnf file seems to be ok, (see attached file)

thx in advance.

best regards.
server.txt (14.8 KB)

Do you have central user management configured, if yes then check the ACL’s if they includes MWS role from “central” provider.

If Central user management is not configured then the user with which you logged in MWS should be present on IS as well and again configured in proper ACL’s as well.

Yes, I’ve central user management configured.

I send you my actual configuration. Still it doesnt work.

Administrators ACL: system/My webMethods Administrators
Anonymous ACL : system/My webMethods Users
Default ACL : system/My webMethods Users
Developers ACL : system/My webMethods Administrators
Internal ACL : system/My webMethods Administrators

regards, thx

What is the value for “watt.server.auth.samlResolver” in extended properties.

It should be pointed to ur MWS server…

watt.server.auth.samlResolver=http://MWSHOST:PORT/services/SAML

Its pointing to MWS server.
watt.server.auth.samlResolver=http://localhost:8585/services/SAML

thx

IS the backward slash a typo or you have it there, if yes there thats the wrong entry… please correct and then try…

See the server.txt attached. Seems to be an escape character for :, and its specified for other settings in server.cnf. sorry, ¿are you sure?

It should be

watt.server.auth.samlResolver=http://host name:port/services/SAML

Please refer to webmethods documentation for the same.

Resolved with flow service permissions from designer, I’ve changed the execute ACL to Developers ACL which have my windows domain group.

Thx, best regards.