856 SN105 won't accept numericFormat?

I am trying to map an 856 document from a flat file. After mapping the “number of pieces ordered” into SN105, I then have another step to convert SN105 to a numeric format (pub.string.numericFormat)…

The value still comes out as “9.24E2” rather than 924. I vaguely remember reading somewhere that this field has that format (scientific notation) but is there no way to override this?

Ps - if the field is not meant for this value, it is irrelevant, as the customer wants the pcs ordered to be placed here, so I need some sort of solution…

Thanks,

I. Jamal

One way is to turn off the use of the formatting services for EDI. In IS Administrator, go to EDI under Solutions. Click Configure Field Formats. Set isEnabled=false. Review the EDI User’s Guide for more info.

We have about 200+ mappings that probably use the field formatting in some way…if I turn it off, I would need to go through those and add custom formatting…
Is there no other option?

No you shouldn’t have any issues with other maps…but I would say first turnoff section below in a lower level environment (DEV/QA) and test it:

<FormatService name=“formatDecimal" isEnabled=“true” internalFormatString=”#.##########" externalFormatString="#.#####E0" applyFormat=“false”/> —> from true

HTH,
RMG

The docs cover the level of control you have via configuration.