XSLT Windows v's Unix

I having a problem processing XSLT on unix at the moment, it works fine on windows but when I try process the same file on Unix I keep getting the same error. I’m wondering does anyone know is there a difference between the two operating systems that maay cause this problem…if so have you any solutions
Most current operating systems have an XSLT processor installed. For example, Windows XP comes with the MSXML3 library, which includes an XSLT processor. Earlier versions may be upgraded and there are many alternatives, see the External Links section.
Seems like JMeter is generating some dodgy XML, but not sure why that wouldn’t fail on Windows also
JMeter uses an XSLT file, jmeter-detail-report.xsl to transform the JMeter JTL output into a nicely formatted html table of results.
The version of the file which I run with ant-jmeter (as a task in build.xml) runs well on Windows but fails on Unix with the following exception:
[xslt] Processing /export/home/sfuser/sola/JMeter/JMeterResults.jtl to /export/home/sfuser/sola/JMeter/JMeterResults_detail.html
[xslt] Loading stylesheet /export/home/sfuser/sola/JMeter/jmeter-results-detail-report.xsl
[xslt] : Error! Content is not allowed in prolog.
[xslt] : Error! com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is not allowed in prolog.
[xslt] Failed to process /export/home/sfuser/sola/JMeter/JMeterResults.jtl

/export/home/sfuser/sfv4-client/staging/sfv4client_jmeter.xml:132: javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is not allowed in prolog.

I tried removing spaces, changed the xml prolog in the xsl file, etc but it still doesn’t work.

Could you suggest what I can do to fix the problem?



there are definitly no differences between XSLT on UWindows and UNIX - just some differences in file handling - e.g. end-of-line handling - but those whitespace characters probably do not explain your issue.


I don’t use Windows at all, but I have gotten the impression from what other people say that MS software sometimes ignores errors that often should be fatal if the specs were followed strictly.

It’s not clear to me if the error is in the stylesheet or in the input file, but the error is saying that you have something other than white space, comments or processing instructions before the start tag for the root element of an XML document.