xsl is not applied through tomcat

Following some of the previous postings on the passthru servlet I have got far enough to install it and have the test running correcly, but now I’m a bit stumped.

The passthru servlet is installed in /webapps/passthru and works fine since calling http://myserver:5573/passthru/servlet/test returns the expected page.

I have copied from previous postings the shema for the xsl page and loaded it into database: Moademo & collection: stylesheets

I have created a simple xsl transformation - Filename: Style1.xml
<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version=“1.0” xmlns:xsl=“http://www.w3.org/TR/WD-xsl”>
<xsl:template match="/">

Here are the results for your query:



<xsl:for-each select="//ArchObj">




</xsl:for-each>

Label: <xsl:value-of select="@LABEL"/>

Type: <xsl:value-of select="@TYPE"/>



</xsl:template>
</xsl:stylesheet>

and loaded it into the collection. I know it is in place correctly because the query
http://myserver:5573/tamino/Moademo/stylesheets?_xql=//xsl:stylesheet
returns the stylesheet Style1.xsl

I have tried the stylesheet against one of my xml files with XMLSpy and I do obtain the
output that I expected, so I know that the xsl transformation works for my files.

My xml files are in Database: Moademo & Collection: moa2

However, when I use the following query:
http://myserver:5573/passthru/servlet/filter/tamino/Moademo/moa2?_xql=//ArchObj&_xslscr=http://myserver:5573/tamino/Moademo/stylesheets/xsl:stylesheet/Style1.xsl

gives me results as there was no filtering at all through the xsl that is I got the same results that I would get using
http://myserver:5573/tamino/Moademo/moa2?_xql=//ArchObj

I’m clearly missing something, and I hope that somebody can point out it to me.

Thanks in advance,

Giuli

Hi,
You have checked that a query returns the stylesheet, but the passthru servlet gets the stylesheet by docname. Does this URL:
http://myserver:5573/tamino/Moademo/stylesheets/xsl:stylesheet/Style1.xsl
also return the correct stylesheet?

This is probably just a posting typo but in your post you wrote the passthru URL as: http://myserver:5573/passthru/servlet/filter/tamino/Moademo/moa2?_xql=//ArchObj&_xslscr=http://myserver:5573/tamino/Moademo/stylesheets/xsl:stylesheet/Style1.xsl

It should be …&_xslsrc…

HTH

Bill,

you are right, I tried to execute the query http://myserver:5573/tamino/Moademo/stylesheets/xsl:stylesheet/Style1.xsl
but I got back an error. So I checked the xsl with
the X-Plorer and found no trace in the file about SStyle1.xsl

To store the xsl in Tamino, I have followed the documentation that suggests to use the Interactive Interface entering in the DatabaseURL
http://myserver:5573/tamino/Moademo/stylesheets/Style1.xsl and load with the Process option. However, when I did that I got the following error

<ino:messagetext ino:code=“INOXRE8814”>Element/attribute name not found</ino:messagetext>
ino:messagelineElement name = Style1.xsl</ino:messageline>

and I later loaded the file by just using
http://myserver:5573/tamino/Moademo/stylesheets
in the DatabaseURL which, I see now, just gave me the ino:id=2 setting.

How would I go about making sure that the name is stored through the Interactive Interface? Or by any other method?

thanks again.

Giulia

You nearly had it! The first technique is the right one but your Database URL didn’t include a document type. It should be:

http://myserver:5573/tamino/Moademo/stylesheets/xsl:stylesheet/Style1.xsl

HTH

And please remember the stylesheet works with a query result now and not the xml file.
The “root” element is not “/” but “/ino:response/xql:result”

<xsl:template match="/"> should then be modified accordingly.