XML Schema loading Challenge

Your Schema uses includes which may be chameleon includes, which are not supported by IS. You probably need to import specific namespaces instead (ie create namespace for all xsd’s you current include and import them instead).

HTH
Serge

Hey Serge,
What do you mean by "import specific namespaces ". How can we import namespaces in webmethods. I am facing a problem while creating web service connector and it throws the same error saying “Definition not found.”
If you can make more clear about how to import namespaces .

  • nilesh

Hello,

Can anyone give a small example of how to fix the Chameleon Includes. I am having the same issue and can’t figure out how to do the work around. I am trying to import an EAN.UCC v1.3.1 schema into IS 6.1. Specifically the Forecast.xsd file in the attaced zip.

Thanks,
Tom

Forecast Implementors Packet
Forecast_Implementers_Packet.zip (26.1 k)

Thomas,

What is the exact error you are seeing when loading this Forecast.xsd in the Developer?

Hi RMG,

Thanks for your reply. I have attached the errors I am receiving in a txt file. It looks long, but most of the errors are

errorMessage: [ISC.0082.9705] Definition not found.

I appreciate your help with this.

Thanks,
Tom

Errors
Errors.txt (11.4 k)

Thomas,

I am not sure how to resolve this issue.
Actually namespaces xmlns looks fine in all the xsd’s (xmlns:xsd=“http://www.w3.org/2001/XMLSchema”) should import fine in the IS.

Did you tried to validate these schemas in XML SPY like that?

As a last option try to contact WM support since IS6.1 behaves differently for these EAN UCC schemas.

HTH,
RMG.

RMG,
Thanks for your reply. Can you tell me how I would validate the schema in XML Spy. I can open it in XML Spy without error. Is there something else I can do to validate?

I will contact wM support regardless, but I am curious to know if there is something else I can do in XML Spy to validate.

Thanks,
Tom

If it is opening in the XML SPY without error,then the schema is valid, but some how the WM is not finding the expected definitions based on the w3c,EAN namespaces.

To Thomas and maybe to Carl

Serge above is right, you cannot use chameleon includes in wM. The only way we have got around the problem is to add the same namespace information to all of the included schema files. They’re no longer chameleon I’ll admit, but it works.

Thomas, if you add targetNamespace=“http://www.ean-ucc.org/schemas/1.3.1/eanucc” xmlns=“http://www.ean-ucc.org/schemas/1.3.1/eanucc” to each of the included files the schema should import into wM successfully.

Carl, probably the same. If you add targetNamespace=“http://www.opentravel.org/OTA/2003/05” xmlns=“http://www.opentravel.org/OTA/2003/05” to each of your included schema files it should work for you too.

Darren,

Thanks! That worked! I was sure that was going to be the end of the post on the 11/5. Thanks for responding.

Tom