X-App build fails when defining schemas to Tamino

X-Application Version: 4.1.1
Tamino Version : 4.1.1
Platform : Win2k
WebContainer : Tomcat 3.3.1
JDK Version : 1.3.1

Hi there.
My x-app build keeps failing during the setup of the collection to Tamino with t6he following message…

setup.collection:

defineSchema.internal:
[java] defining tsd schema: C:\xapp4\xapplication_4_1_1_4\xapplication_411<BR>testsuite\xmlfiles\property\property.tsd -> http://localhost/tamino/welcome_4_1_
1/xapplication4.1.1.4
[java] StoreException: id = 161 arg[0] = defining new schema failed: Nested
Exception:Tamino access failure (INOXME8554, No message received)
[java] Nested Exception (com.softwareag.tamino.db.api.common.TAccessFailure
Exception, tag: $Name: JavaTaminoAPI_4_1_2_41 $) stacktrace:

[java] Tamino access failure (INOXME8554, No message received)
[java] at com.softwareag.tamino.db.api.accessor.TAccessFailureVerifier.
newAccessFailureException(TAccessFailureVerifier.java:126)
[java] at com.softwareag.tamino.db.api.accessor.TAccessFailureVerifier.
verify(TAccessFailureVerifier.java:113)
[java] at com.softwareag.tamino.db.api.accessor.TAccessFailureVerifier.
verifyDefineResponse(TAccessFailureVerifier.java:90)
[java] at com.softwareag.tamino.db.api.accessor.TAbstractSchemaDefiniti
onAccessor.define(TAbstractSchemaDefinitionAccessor.java:81)
[java] at com.softwareag.xtools.xapplication.schema.Define.defineTSD(De
fine.java:470)
[java] at com.softwareag.xtools.xapplication.schema.Define.defineTsdAnd
Get(Define.java:192)
[java] at com.softwareag.xtools.xapplication.schema.Define.define(Defin
e.java:165)
[java] at com.softwareag.xtools.xapplication.schema.Define.main(Define.
java:107)
[java] Exception in thread "main"

BUILD FAILED
file:./misclib.xml:243: Java returned: 1

I have read the message in the installation section of the document that reads…

"Important:
The setup.cmd command script fails if you want to access Tamino XML Server via an HTTP server that is protected with BASIC authentication. To install Tamino X-Application properly, you need an HTTP server without authentication check. Also, you must not protect the collection ino:collection with authentication rights, because the installation process of Tamino XML Server X-Application inserts new schemas. "

So what I did was adjust the XML properties in the Tamino manager for Welcome_4_1_1 db to authentication = none. I then bounced the DB so the values took effect.

I also commentated out all the Tamino Manager configurations in the x-app conf because I am working with Tomcat 3.3 that has no manager.

Is it possible to run X-app 4 with Tomcat 3.3? I really do not want to change my stable Tomcat installation as i have so many other products and demos running quite nicely on Tomcat 3.3.
(everything except x-application 3 or 4 of course)

I do see on Tamino Dev co that “Setting up X-Application 3.1.3, in a Tamino XML Server 4.1 environment, will fail during the “Schema definition” step”, is this what could be happening with my x-app 4 installation, should I modify the schemas as you would for x-app 3 with Tamino 4?

Hello,
Did you try generating the application from GUI or command line?
I also had Tamino Access Error when trying to generate from GUI.
It worked when I tried generating through the command line.
You might try this out.
Server

Hi,

can you access your database if you use Tamino X-Plorer?

Tomcat 3.3 should work. However, upgrading to 3.3.1 is preferable, we’ve seen strange failures with 3.3.

Michael

Software AG Germany, Darmstadt

Hi Michael.

I can access my Welcome_4_1_1 db from Tamino Xplorer, no problem. I am using tomcat 3.3 final, I’m very weary of upgrading my Tomcat because of all that I have built on the current version.

Mehmet, I am running the x-app4/setup.cmd from the command line, I’m not sure what GUI is available to build x-app.

From what I can tell by the error message, the problem is not with Tomcat (yet) but rather with the x-app build procedure failing to write the schemas to Tamino. I can see i’m going to have other problems with Tomcat because the build does not create a xapp folder it dumps 16 xapp*.xml files under the webapps folder. I don’t think that’s the way it should be, is it?

Hi,

a couple of thing to say …

o using X-Application 3.1.3 with Tamino 4 is tricky, but you’re using X-Application 4.1.1, you don’t have to adjust your schemas.

o setup.cmd has no gui, I’m not sure what MehmetServer is refering to

o the setup generates various xapp*.xml into Tomcat’s Home directory. These are Tomcat 4.1 specific, Tomcat 3.3 does not support them. You have to manually collect all “context” elements from these files and place them into tomcat/conf/apps-xapplication.xml. (xapplication 3.1.3 generated this file, please have to look there to get that idea)

o My first idea was: maybe the schema definition problems is due to your authentication setup. But you said you’ve disbled authentication. Is it possible to create a new database (without any special setting) and run setup with it? Sorry, currently I have no better idea …


Michael

Software AG Germany, Darmstadt

Hi Michael.

I created a new DB and tried to run the build again, which failed for the same reasons (Tamino access failure).

Let me ask a few basic questions.

1) My Tamino DB and Tomcat were running when I attempted to build Xapp, is this correct?

2) When I remove authentication - I use the Tamino manager, go to the DB/properties/XML and I adjust the authentication from Web Server to None, is this correct?

3) If the build fails from the setup.cmd in defining the schemas, can I attempt to manualy define these schemas to Tamino? And if i do this, will I be able to run X-app (after collecting the files into a new xapp foler in Tomcat) or is there more that happens in the setup.cmd build that happens after these schema definitions?

Regards
Neil

Hi Neil,


… some basic answers …

1) Correct. A running DB is a must. A running tomcat doesn’t matter.

2) I’m not sure. I ask some guy who knows about authentication - here’s what I understood: Tamino’s default authentication setting (i.e. the setting for the switch you mentioned in your question) is “web-server”. That’s fine even though the web-server’s default configuration doesn’t actually do authentication.

If you changed your web server configuration to do authentication, you need to revert these changed. Tamino’s authentication setting should be “web-server” (which sound’s confusing because there’ll be no authentication).

You can definitly get better ansers on the Tamino community …

3) Yes. Defining the schema (and following this – defining some example data) is the last setup step. X-Application itself should, but the example will not.
Manually defining a schema is a good idea! Please keep me informed if you can define the schema with Tamino’s Schema editor.

Michael

Software AG Germany, Darmstadt