WSC losing reference

Hello all,

I’m having a problem with Web Service Connectors.

I have a WSD with a single operation, then I created a WSC and started my page development. Well, it’s worked!

I was using my page normally, so i had to add another operation in my WSD and create another connector. When I created my new connector, the other one lost the reference, the connector it’s a blue triangle image, after I created the new connector it becomes a yellow ball. All page is getting error, because don’t find nothing.

Why is this happening? I tried to create another WSD, another WSC, another page, but the error didn’t dissapear

Thanks!

You should be able to just refresh the existing WSC to pick up the changes rather than creating a new one. Did you already try that?

Yes, instead of creating another one i refreshed. My mistake on writing…

Resolved!

I saw in other topic that Designer 9.8 changed packages/folder default.
"I wonder if you are using Designer 9.9. In that case, to change packages or folders “src -> caf -> war” you have to go to:
Windows\Preferences\Software AG\UI Development, then inside of the inputText named “Default Java Package” change the value “caf.${project_type}.${project_name}” with the new value, for instance “com.webmethods.caf”. "

But I have created before I change this configuration, so I open all .java and I changed manually of caf.war to com.webmethods.

Thanks!