Write file to a Shared Drive

Hello All,

i know that some one had already faced this issue and worked on it to resolve this. But, now I am facing this issue and couldn’t find any solution. So, please help me out ASAP.

Issue: need to write a file on a network shared drive
Env: wM 8.2
Source file location: its from Unix box
Target file location: to network shared drive and I am using my credentials to run the service as i have read/write permission to that drive (NO FTP on shared drive server)

Tries: 1) I tried using the writeToFile(custom java & wMSamples Pkg service) but no luck
2) My inputs are Z:\Test (its a network shared and I mapped it to my IS as my IS runs on windows machine)
3) Used IP of the shared drive server but no luck

Any thoughts are appreciated.



To write a file from unix OS to windows OS you need to have a mount point created on unix(that points to windows shared location). Talk to your unix/linux admin to create mount point for you.
Also its not your userID that need to have access but the userID of the linux box(where your webM is running) that need to have access.

Once these are done then you can use the url which looks like usr/local/{mountpointname} to write your file.

Thank you,

Mapped drives work only for logged in users, not Windows services (even if the service uses logon as credentials).

Use a UNC name to refer to the network share. \servername\dirname\file

I usually avoid using network shares (Windows) and mounts (Unix) in integrations. They can be flaky and a pain to troubleshoot.