WorkFlow Servlet configuration with IS

Hi ,
i am creating a project using workflow thin client i.e. browser based inbox ,for this i have copied the “workflowserver\workflow.war” from workflowserver to the “Integration Server\web” of Integration server
BUT this doesn’t work , what else do i need to do?

Did u enable the WmWFServlet package on IS? workflow.war file should be copied in the web folder of this package.



I ran into a problem where my WmWfServlet package was enabled during Integration Server startup, however it became disabled by the end of the startup.

When I tried to enable the WmWfServlet package via webMethods Admin package management, it would not enable.
I did find a problem and solution in Advantage that I thought would fix my problem. It was fix ( So I followed the instructions and restarted the IS but the wmwfservlet package still did not stay enabled. I finally got it to stay enabled by making the WmWfServlet package dependent on the WmTomcat package. How do you do this if you can’t set the package dependency using webMethods Developer? Well, you can modify the package Manifest.vs file (found in the package root folder). For example,
I manually edited the Manifest.vs file for WmWfServlet (in folder: C:\webMethods65x\IntegrationServer\packages\WmWFServlet) and added the following:

 <record name="requires" javaclass="com.wm.util.Values">
<value name="WmTomcat">6.5.1</value>

After restarting the Integration Server the WmWfServlet package stays enabled and there aren’t any exceptions.

Here are snippets from my server log file showing the initial load and enabling of the WmWfServlet package (1) and the exception that occurs later without the dependency on WmTomcat (2).

 ******* 1 *******
2007-03-28 11:29:04 EST [ISS.0028.0005C] Loading WmWFServlet package

2007-03-28 11:29:04 EST [ISS.0028.0032V1] Package WmWFServlet is now operational.

******* 2 ********

2007-03-28 11:30:00 EST [ISS.0100.0008D] Processing Context configuration file URL file:C:\webMethods65x\IntegrationServer\web\conf\WmTomcat\localhost\web#WmWFServlet.xml

2007-03-28 11:30:00 EST [ISS.0100.0008D] Installing web application from URL file:C:\webMethods65x\IntegrationServer\packages\WmWFServlet\web

2007-03-28 11:30:00 EST [ISS.0100.0008E] Skipped installing application listeners due to previous error(s)

2007-03-28 11:30:00 EST [ISS.0100.0008E] Error listenerStart

2007-03-28 11:30:00 EST [ISS.0100.0008E] Context startup failed due to previous errors

2007-03-28 11:30:00 EST [ISS.0100.0008D] Removing web application at context path /web/WmWFServlet

2007-03-28 11:30:00 EST [ISS.0100.0008D] Processing Context configuration file URL file:C:\webMethods65x\IntegrationServer\web\conf\WmTomcat\localhost\web#WmTomcat.xml

2007-03-28 11:30:00 EST [ISS.0100.0008D] Installing web application from URL file:C:\webMethods65x\IntegrationServer\packages\WmTomcat\web

Hopefully this post helps someone out.

I posted the same problem and solution @ wM Advantage.



webMethods Professional Services


can you please tell me from where in the advantage site, can I download the WmWFServlet package for wm 6.5? I installed workflow server for 6.5 and I didn’t find this package in the IS.