WmTN pkg failed to load with OutOfMemory exception caused by endless loop in a processing rule ...

We are having a catch-22 problem.

A working WebMethods was brought down after a change in a processing rule. But restarting it never get successful.

wmTN pkg failed to load with OutOfMemory exception … caused by endless loop in the modified processing rule. Therefore TN console can’t start.

The problem is how can the modified processing rule that is looping endlessly be modified or taken out all together without TN ?

All tried with no alternative other than a fresh re-install and deployment; the issue here is we didn’t backedup for about two weeks.Therefore,we are doomed to configure processing rules etc from scratch.

All suggestions are highly appreciated !!

G.G

Desible some of the other packages and then try to load the package. it will be loaded. after that you can enable the disabled packages.

Thanks Atulsahire !

But the problem here is a Processing rule with an infinite loop until all memory is used . The error won’t allow TN to start up as system runs out of memory before TN start up is successful.

with no access to TN console how can a processing rule be fixed ?

Thank you !!

This is a pretty bad problem - contact support.

You may need to login to the database server and modify the TN database directly. The TN database has a table called PROCESSINGRULE where TN processing rule data is kept. I think you can manually disable a specific rule (there is a DISABLED column in this table).

Caution: I haven’t done this myself - do talk to support about this.

Thanks Atulsahire and Sonam Chauhan !!

Configuration Engineers were able to get into TN by disabling all the non-webMethods-installed packages and reloading wmTN.

As exactly suggested by Atulsahire ! Unfortunatelly I was not able to communicate the suggestion to the folks working on the issue, thinking probably Atulsahire misunderstood my question I tried to elaborate my question the second time instead. The Good thing is some bright mind took care of it.

There is issues around it still, that need some more work.

I will try to post the resolutions taken once the environment is fully functional.

GG -