Wm6 wmb2bediconvertToString

I’d gotten most of our EDI done up with 4.6, when we decided to migrate to 6.0.1. For the most part, the migration is going smoothly, and in fact, I far prefer 6.0.1’s handling of flatfiles and EDI in general.

The main impetus behind upgrading was the vastly improved generateFA service.

Anyway, under 4.6, wm.b2b.edi:convertToString trimmed spaces, but under 6.0.1 it doesn’t. I’d really really like for it to. I saw the “spacePad” parameter, and thought that if I set it to “none” it might fix everything, but all that does is prevent it from adding spaces - it doesn’t actually remove ones that are already there.

When you’re being charged by the character, I guess every space counts

Thanks for whatever help you can give me (I really don’t want to have to put a “trim” transformer on every field map - I know it’s possible, but I’d like to avoid it)


Interesting but I never saw that convertToString removed spaces so I used the trim as the last step in my service when mapping records and as the last step in a loop when mapping recordLists.
Therefore a non-issue for us when we migrated to 6.0.1.

Good Luck!