WM Host Name Rename

I have to reconfigure/rename HOST NAME of existing webMethods 9.7 installation setup which includes

  • WM 9.7 Servers on OS is AIX
  • WM 9.7 Servers on OS is Window
  • MWS
  • Enterprise Gateway Servers

Kindly share what all configuration files I need to modify to achieve this work around ?

This link should help you fetch the information.

http://tech.forums.softwareag.com/techjforum/posts/list/55883.page

Hi Mahesh/Wm Forum Member,

I have run through that KB article but it seems there is lots of version difference the article was for version 9.0 and mine WM ruining in WM 9.7.

I am unable to compare mine 9.7 configuration/directories on OS AIX(IBM Unix box) so can some one pls help me out here ? Not able to find mention conf files in location/path mention in that KB article

Resolution:
The following are what we did to get MWS to run after wM and it’s DB hosts changed.

  1. To change the DB connection:
  • Edit the /MWS/server/default/config/mws.db.xml file
  • Change the DB connection properties including: hostname, service name, username, and password
  1. To change the MWS’s node name and hostname to reflect the current environment:
  • Run /MWS/bin/mws.sh -s default getconfig cluster.xml
  • Edit /MWS/server/default/config/cluster.xml file
  • Change all references of old hostname/IP-Address to new hostname
  • Edit /MWS/server/default/bin/server.properties.sh file
  • Change “NODE_NAME” environment variable (at the bottom) to reflect current hostname.
  • Edit /MWS/server/default/bin/instance.properties file
  • Change “node.name” property to reflect current hostnam

Hi Vinay,

looks like your message got truncated while submitting.

For the IntegrationServer the structure has changed in wM 9.6:
Instead of IS/config it is now IS/default/config

It is now possible to have multiple IS instances in one Installation Root.

Regards,
Holger

Vinay – I agree with Holger, from 9X version onwards there is a little change the in FS. you should do a little efforts with which you will get clear.

Thanks,

Don’t worry about the version numbers, please identify the files that mentioned in he article and try to modify accordingly.

Guys,

This was mention in KB articles

  1. To change the DB connection:
  • Edit the /MWS/server/default/config/mws.db.xml file
  • Change the DB connection properties including: hostname, service name, username, and password
  1. To change the MWS’s node name and hostname to reflect the current environment:
  • Run /MWS/bin/mws.sh -s default getconfig cluster.xml
  • Edit /MWS/server/default/config/cluster.xml file
  • Change all references of old hostname/IP-Address to new hostname
  • Edit /MWS/server/default/bin/server.properties.sh file
  • Change “NODE_NAME” environment variable (at the bottom) to reflect current hostname.
  • Edit /MWS/server/default/bin/instance.properties file
  • Change “node.name” property to reflect current hostname
  • Edit /profiles/MWS_default/configuration/custom_wrapper.conf file
  • Change “set.NODE_NAME” to reflect current hostname

below configuration look like in my WM 9.7 OS AIX unix box
i didn’t find most of the mention path/dir structure in my unix box

bash-4.2$ cd /profiles/MWS_default/bin
bash-4.2$ ls -ltr
total 232
restart.sh
daemon.sh
startDebugMode.sh
startup.sh
shutdown.sh
console.sh
setenv.sh
sagmws97_default
eclipse.ini.ignored
custom_setenv.sh

cd /profiles/MWS_default/configuration
bash-4.2$ ls -ltr
shiro.ini
ehcachesin.xml
security
org.eclipse.equinox.simpleconfigurator
logging
jaas.config
PlatformManager
wrapper.conf
org.eclipse.equinox.app
com.softwareag.platform.config.propsloader
custom_wrapper.conf
config.ini
org.eclipse.core.runtime
org.eclipse.osgi

Vinay – What all FS’s didn’t you find, please list down so that I can help you out.

Thanks,

Hi MR,

Below listed conf files i didn’t find or may be i am unable to locate them, can you pls look into this ?

  • Change all references of old hostname/IP-Address to new hostname
  • Edit /MWS/server/default/bin/server.properties.sh file
  • Change “NODE_NAME” environment variable (at the bottom) to reflect current hostname.
  • Edit /MWS/server/default/bin/instance.properties file
  • Change “node.name” property to reflect current hostname
  1. To change the DB connection:
  • Edit the /MWS/server/default/config/mws.db.xml file
  • Change the DB connection properties including: hostname, service name, username, and password

Team,

Waiting for response Did you need any further information?
Appreciate your response

Hi Holger/Mahesh/Team,

WM 9.7 OS AIX(Unix)

I am in progress of renaming my WM host name at console level, almost 70% activity has completed but below display issue i am facing in console level.

While I login to WM console admin page -->

1.Schedulers --> “Target name” still show old server host name not reflecting new server name ?
2. Logs --> Security --> security logs still show old server host name not reflecting new server name ?

Do any one knows which file or location i need to modify so that this Display of old host name of IS will reflect with new server name?

Hi Vinay,

did you shutdown and restart the IS since then?

Additionally check for the Extended Setting “watt.net.localhost=”.

What is displayed in the top left corner of IS Admin?
Is this reflecting the new value?

ABout the Schedulers:
This value is stored in the ISInternal Database in the table IS_USER_TASKS.
To change it, open each scheduler and save it without further changes. This should update the entries.
You should consider to set the Schedulers to run on “Any Server” as this will not be affected the next time you change your hostname.

Regards,
Holger

1 Like

In extended setting i have change “watt.net.localhost=” and restarted IS but still no luck.

In top most left corner i can still see old host name and even in my security logs server id show as old name
Is there any other ways to change this display cserver host name to new host name?

Regd Scheduler
I have access to ISInternal Database in the table IS_USER_TASKS and even i can see entry of old host name in table data but not able to modify it, it’s not allowing me to modify?

Hi Vinay,

can you try to modify the schedulers via IS Admin as described in my previous post?

For the hostname in the IS Admin page:
Maybe you will need to do some more investigation why the new host name is not detected by the lookups.
Are you able to resolve the hostname vs. P adress by nslookup?

Regards,
Holger

Hi Holger,

Thanks for quick response

  1. Scheduler Yeah I am able to modify scheduler and make them Target as 'Any server" but my issue is while creating new scheduler in drop box it’s still show 1 any server and old host name.

  2. Yeah I am able to resolved IP Vs host name it’s match and look good

Vinay,

Did you modify AuditConfig.xml there is xml tag .

Make sure to restart IS. Let me check the other things that you have mentioned.

watt.server.scheduler.logical.hostname did you check this setting on IS admin guide?

  1. Schedulers issue watt.server.scheduler.logical.hostname

after adding host name explicitly in extended setting it’s work out but still i have question don’t you think we are forcefully resolving this host name via extended setting but instead of this be has to modify as per Holger suggestion or handle at DB level, I can see entry in DB table IS_USER_TASKS but not able to modify them.
Is this correct way of fixing this ?

  1. I have modify AuditConfig.xml there is xml tag with new host name but don’t know come old value is getting reflected again after restart of IS.

  2. IS admin console – logs – security - i m stilling getting “server id” has old host namr

Forum members,

Any more suggestion for above listed issue.
Appreciate your response

Issue resolved.

new host server name was missed to added at OS level
Hence Issue has been resolved