"wm_fabric_nav_mainnav" portlet usage

Hi guys.

I have hit a problem while trying to use the “wm_fabric_nav_mainnav” portlet in order to display the contents of a CAF folder: the “Tasks” folder (contains a task application).

I am using the portlet as part of a Shell Header and I am loading the Shell via a Shell rule on login.

The problem is when I login with a regular user the portlet is not rendered at all, but when I login with a user who is part of the “My webMethods Administrators” the portlet is correctly rendered.

I have already double checked the permissions configuration for the regular user and the user has all permissions on the task application.

Additionally, here is the portlet configuration:

<wm_fabric_nav___mainnav
authLevel=“forms”
creationDate=“1318411451792”
css=“nav,nav2,nav3” depth=“2”
description=“wm_fabric_nav___mainnav”
exclusive=“true” isVersioned=“false”
lastModifiedDate=“1318411451792”
leaf=“current.resource”
name=“wm_fabric_nav___mainnav”
order=“ascending” ownerID=“sysadmin”
roots="{webm.apps.workflow}"
showFirstLevelSpecial=“false”
showMenus=“false” showTabs=“true”
sort=“sortid” sortID=“0”
taskFoldersOnly=“true”
tempAlias=“temp_alias_6”
userAlias=“shell.export.EbfHuShell.wm_fabric_nav___mainnav”
userID=“sysadmin”>







</wm_fabric_nav___mainnav>

My feeling is that I still need to configure something so that the regular user has access to the portlet.
Is that correct or am I missing something else?

Any help is appreciated.

Thanks,
Teodor Pop

It looks like you’ve added some default acl’s to the portlet via the xml:

<ace action="removeAll"/> 
<ace action="add" uid="Everyone"><right 
deny="false" grant="true" name="portlet.read"/> 
</ace> 

I’d recommend trying to go to the permissions for this portlet. First check to see if it is part of Security Realm. If not, try experimenting with the permissions on that portlet.

If all else fails, please export the shell(with permissions) and attach it and i’ll take a look.
Regards,
–mark

Here is what I tried:

  1. Configure the permissions on the portlet in the shell section edit screen
  • configured directly to the regular user with grant all → no change
  • configured to the regular user role with grant all → no change
  1. Configure the permission on the portlet in the System/Portlets location
  • same both cases → no change
  1. By default the portlet is not assigned to any security realms.

So I configured a new security realm with one object: “System/Portlets/vm_fabric_nav” and granted all permissions (once on regular user role and once on regular user directly).
Then I configured the security realm on the portlet in the Shell Section edit screen → no change.
I also tried with the “System/Portlets/vm_fabric_nav/wm_fabric_nav_mainnav” object as part of the security realm → no change.

I also tried assigning the porlet to the task application security realm → no change (and I also added the porlet to the task security realm)

Should I try with any other particular Security Realm?

I also attached the shell as it is currently configured (permissions configured via xml)

Thanks,
Teo
wm_EBFHUShell.zip (1.9 KB)

Could you please repost that file? This forum is saying that it has been deleted. Not sure if that is true or not… Maybe just upload it with the .zip extension please?

Thanks,
–mark

I replaced the attachment with the zip file.

I also just now realized I forgot to mention that I am trying this on MWS 8.2.

Do those users belong to the My webMethods Users role?

Yes, the users are part of the “My webMethods Users”.

I checked again the configuration and also tested two configurations:

  • the users are directly members of the “My webMethods Users”
  • the users are members of a “common role” and the “common role” is a member of “My webMethods Users” (this is default setup)

In both cases, same result, no navigation portlet displayed.

I’m sorry that i haven’t got back to you sooner. Are you still stuck?

We were not able to make any progress with the topic.

For now we have postponed the topic and we plan to retry the implementation at a later date.

I will come back to this thread when we have updates (and hopefully some good news).

Solution provided by SAG support.

The problems was the missing access privileges configuration for My webMethods Applications for our particular MWS role.
(Note: task privileges were already assigned via Permission Management → Tasks).

Video guide as provided by SAG support is attached.
Permissions.zip (2.95 MB)