Wm 8.0 XSLT 2.0 Transformer Issue

Hi All,

Could you please help?. We tried to run an XSLT code in WM8.0 but it is getting failed with the following error

“com.wm.app.b2b.server.ServiceException: [XSL.0002.9001] JAXP: Error instantiating transformer - Failed to compile stylesheet. 1 error detected”.

We’re using “net.sf.saxon.TransformerFactoryImpl” transformer.

and the style sheet contains the following
<xsl:stylesheet version=“2.0” xmlns:xsl=“http://www.w3.org/1999/XSL/Transform” xmlns:xs=“http://www.w3.org/2001/XMLSchema” xmlns:fn=“http://www.w3.org/2005/02/xpath-functions” xmlns:xdt=“http://www.w3.org/2005/02/xpath-datatypes”>

Can somebody help us…

Hi,

I’m also getting same error.

Did you fix this issue.

Please let me know the solution.

Thanks
sandy

Any word from SAG product support that makes me wonder If this a global issue?

This might be configuration issue as it’s saying that it’s unable to instantiate. Not sure if you followed the configuration correctly [like pointing TransformerFactory to the the desired parser] as the default parser used by IS is xalan

did you check if there are any special characters in XSLT OR in you XML data ?