Why canbt I get input from a file

I have code a test service which has an document input and some String variables.In this test services I have a “map” flow in which I mapping some fields of input document to the output variable.When I run this service ,it thread an error “cannot enter data for recursive document types” .but When I used the similar document “Course_BookOrder” that provided by webMethods,the IS didn’t thread any errors. I am at a loss by these phenomenons,Is there some one meets this kind of problem?Can you help me to solve it?Thank you for your interest in my question.

Can you elaborate your mapping process that you are handling now?
So that we can resolve the issue in better approach.

HTH,

The problem is solved yesterday,the error is caused by the followed expression:the document type that i used is created by empty ,so it didn’t accept the XML file input,I re-created a document type by XML file,then it can get input from XML file.
but a new problem appears now:
“Couldn’t load input from that file.
com.wm.util.coder.invalidDatatypeException:[ISC.0076011]illegal file format”.
I have changed several values of document field,but it threads the same error.
In order to be advantageous your help,I have package the package of service and docs that I have developed.please check the attachment file.

I am waiting for your answer with a large empressement.
thank you very much!

the error phenomenons and the code
err.rar (31.1 k)

Sorry,I am not able to open your uploaded file,so attach as a zip format.

Regards,

Hi RMG,
Thank you for your help!
The attachment is ziped by Winzip 8.0.If you couldn’t open it all the same,tell me the tools and its version that you are using .I will use the same tools to zip the file.

Regards

the error information
err.zip (49.2 k)

Dehong try this

hth
T

answer to question
test.zip (7.5 k)

Dehong,

Tikare uploaded some solution above,check it and let me know if that didn’t help you.

HTH,

RMG,Tikare,
I’m very sorry to tell you this solution raised the same error:
“Couldn’t load input from that file.
com.wm.util.coder.invalidDatatypeException:[ISC.0076011]illegal file format”.
Tikare,I want to know whether the test service works well in your IS developer?If it does,Are there some troubles in my developer environment?
Regards.

it worked fine for me and first time what IS are you using and what are you doing when you run the service? ru using Test ->Send Xml File ->Step [or Trace] use F7 to step through each line, what is in the pipeline the step prior to you getting your error?

Ta
T

Hi Tikare,
It didn’t thread error when testing the service by “Send xml file”.Thank you very much!But I want to know why it raise error by running the service directly?Could you explain it for me ?

Regards

ok when you run this program,ru using Getfile to retrieve the file? if so you will need to convert the file bytes to a string and then convert the String to a document [i.e using BytesToString and then StringToDocument].

I’ve amended this and also noted that your original file did not have the xml header declaration[ see enclosed]

this is resolve your query.

hth
T

Amended xml file
7B1Sample_712_test.xml (4.9 k)

update to test
test.zip (10.5 k)

Hi TiKare,
Thanks you very much!This problem is solved very well.But I still have a question:I test the code that modified by you,then IS pop up an input panel in which the file name will be supplied.Now if I supply the detail dir of test xml file,it will go through without error.But if I click the load button and select the xml file ,it will raise the same error of expressed above. it is surprise that it can’t input the xml file by click the load button. Could you explain it for me?

Best regards.

When you use the second service and specify a file name [i.e. a file that exists on a drive relative to the IS server] do you get the exception? The answer to this should be no
Does it occur when try Test → Step [and try to ‘Load’ a file]? if so then 1. do not do this
2. use the service that has the GetFile and use the test xml file you gave, that I corrected. i.e. ensure that the <?xml> is at the head of the file you are testing…I did add this to your original file

T

Hi Tikare,
I have caught Your meaning.If I don’t test the service by clicking the button “load” but by “send xml file”,it will work well.
Thanks a lot!

hope all is working well now and this solved your problem
T
:slight_smile:

Tikare & RMG,
Thank you for your help!

regards