When searching meet a carriage return...

Hi All,

We are currently experiencing a problem. We have our fulltext data from some ICR softwares, some of the data are in format like,

??? ( please note here has a carriage return )
???XXXXXX…

So, the query /xxx[fulltext~=’???’] returns no document. I understand that the result is correct because of the carriage return inside it.

But is there a method to tell Tamino to ignore those white space characters ( eg, \t, \r, \n…) when doing the query, so that it can search across wrapped lines?

Best regards,
Lun

Hi Lun,

Your query looks like a workaround to perform text-retrieval searches of Chinese characters in Tamino.

What Tamino version are you using? If you’re using version 3.1.2 and above, Chinese language support is available, and there are better ways of doing such queries.

You may wish to contact your nearest sales or technical support on how to obtain the necessary software license to enable this feature in Tamino.

If you have the Tamino documentation, please refer to the The Patient Database use-case in the Examples section under Reference in how text-retrieval should be done for CJK text. :smiley: