WebSphere MQ Adapter 60 put not working

Hi all - I created a simple “put” Adapter Service which uses an MQ Connection object (created and enabled via the new MQ Adapter 6.0 Admin console) to put a message on a given MQ Server v5.3 queue.

A similar service worked fine using the WebSphere MQ Adapter 3.0 where the “put” was done via a message handler “put” service rather than the new 6.0 adapter’s Adapter Service approach.

The MQ reason code I’m getting back from the 6.0 adapter service is 2035 which is a security/authorization issue “MQRC_NOT_AUTHORIZED”. Has anyone been able to do this with the new 6.0 MQ adapter?


Ok, perhaps I should broaden the scope of this post. Has anyone been able to create any service (i.e., put, get, peek, request/reply) using this new MQ adapter? We are running IS 6.0.1 SP2 on Solaris 9.

Here is an update to our problems with “put” adapter service using the new MQ Adapter v6.0. Our MQ server Administrator claims that the new adapter is attempting to set the message context information.

The way he explained it, in each message that is created, there is a message descriptor (MQMD) and the data portion. The MQMD contains information about the message including things like what userid created it, what program created it, what character set it’s in, and so forth. A specific subgroup of these fields is collectively referred to as the context of the message. Normally, this is set by the queue manager as it creates the message. In this case, the client application (i.e., MQ Adapter) has indicated that it wants to explicitly set values for this information rather than letting the qmgr set them.

So to get around this in the interim, he granted this expanded “write” access to the MQ Adapter put service. This solved the problem of the 2035 reason code we were getting and he verified that our message was indeed put on the specified queue.

Hope this helps!

Rajesh et al:

I have a question related to the PUT command the associated MQMD Header data.
When I attempt to use a PUT adapter service for MQ Adapter (v6), I set the Report field to what the target application requires. I’m receiving a “Report Field Missing” error from the application and when I look at the PUT command output the Report field shows “0”.
According to the wM MQ Adapter (v6) docs, the Report field is a string with a maximum of 4 digits (page 73), yet the spec for the target application states that the Report field should look like this:

Is there a translation table or something that I use for this? I’m at a loss as what to do next…
As you may have guessed, I’m a newbie at MQ.

Thanks in advance.