webService not returning output from soapUI

Hi All,

I need your help with a webService. we have worked on a IS service which calls a consumer webService(thirdparty) and we expose our IS service as consumer to another trading partner.

When I ran my service in designer 9. It is returning proper output.

And I wanted to test the wsdl which was generated for my Service from another IS and also tried with soapUI. It is generating something like

From soapUI below is the response.

From another IS: I am getting null as responses.

Whereas if I run my service I am getting proper results. Please let me know if anything is missing.

Thanks in advance.

Hi All,

Any suggestions…??

I am just trying to understand the issue here :slight_smile: I have few questions?

1> IS flow service will call and invoke a consumer webservice (WS connector) and you are exposing (provider) this IS flow service as a consumer to one of the partner? (Creating a WS provider) Am I correct?

2> How are you performing your test on SOAP UI? Did you provide the required credentials in the SOAP UI?

3> Try to re-create the WS provider and retry.

3> Did you try creating a sample WS and try invoking from SOAP UI to check and see that we don’t have any issues with your SOAP UI?

Yes. I have been testing with other wsdl files and was able to receive proper results.

Infact, its not only soapUI. I just tried to provide the wsdl to the Trading Partner. They’re able to make the call but receiving null responses in the fields.

eg: The output field has SUCCESS but they’re getting null value.

Whereas when I execute the flow, i am getting proper value populated in the SUCCESS field.

Hi Kumar,

I am facing same issue as you, did you find root-case of the issue.


Please elaborate more on your issue also and the current setup you have in place… So that it will be easier for every one to respond here :slight_smile: