webService failing some times in production with error ISS.0088.9171


I facing an issue that provider web service is failing in production env with the error ISS.0088.9171: web service cannot found end point references.

restart/reload of the package makes web service working fine.

I tried to check end points references(they were fine)
remaining provider web service is also working good
deleted the existing and created an new one,it is behaving the same way

one issue noticed is when web service is not working,at that WSDL is giving the error(Premature end of life),but reload is of packages corrects the error,not sure how to fix

Can any one help on this?


Does the happen by chance after an IS restart? And are you running in a 8.2 environment? If so you probably have a package dependency problem. A package that your services depend is loaded after the package with the WSD is loaded.

Hi Mark,

Thanks for reply!!!

Yes we are in 8.2 environment on windows server 2008

This not happening at time of restart,it is happening all of sudden and restart the server or reload the package is solution at that time and we are looking for resolution because lot of business is affected at that time


hmm that’s interesting. Any downstream package dependencies perhaps other packages getting reloaded or deployed that this package depends on?

take a look at this fix and see if it might help - IS_8.2_SP1_Core_Fix7

there were no package dependencies and I am not sure whether this fix will help us or not


Hi Mark

Any more idea’s for the root cause!!


See some these things are not normal can impact suddenly but did you tried contacting SAG support on this or install 822 latest fixes core 7 and WS stack updates on the instances?

Check in the Empower also on the IS error code you have been getting to troubleshoot more:


I’m thinking there is some sort of dependency issue or the fix I referenced will probably address your issue. Do you have a dev env. to test it out? We’ve been running 8.2 for a while and the only time I’ve seen this issue was with package dependencies.

And as RMG pointed out if none of that works contacting SAG support might be a good idea.