webService consumer failing "No WS-Security header found"

Hi Experts,

I am developing one service in webMethods8.0 environment which invokes webservice of endpartner’s system.
While invoking webservice via the connector in webMethods we are getting error “No WS-Security header found” whereas when I invoke same webservice in SOAP UI after setting SOAPUI property WSS-PasswordType=“PasswordText”
it is providing correct response set by the partner.

Could anyone please let me know what setting I need to change in webMethods to access same result in develper?

I tried with option setting handler in webService consumer as “WS Security Handler” having different policies including “consumer policy for username”

IS Version:8.0

Any help would be much appreciated.


Do you have a WS end point alias assigned to this descriptor’s Binder?
if not create a consumer type WS alias on the Admin UI, where you should give a username/pass for WS security.

also check if other WS security features are needed for this WS.

Yes we have WS endpoint alias defined for service but that is being used in provider service case not in consumer service.

I have verfied via SOAPUI property WSS-PasswordType=“PasswordText” is going inside soap header tag like below
soapenv:Header<wsse:Security soapenv:mustUnderstand=“1” xmlns:wsse=“http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd” xmlns:wsu=“http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd”><wsse:UsernameToken wsu:Id=“UsernameToken-1”>wsse:UsernameHERA_NAIP</wsse:Username><wsse:Password Type=“http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText”>******</wsse:Password><wsse:Nonce EncodingType=“http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-soap-message-security-1.0#Base64Binary”>r+zKNN0tLvWhoqcDw/5YKw==</wsse:Nonce>wsu:Created2015-01-12T10:37:49.113Z</wsu:Created></wsse:UsernameToken></wsse:Security></soapenv:Header>

It seems this could be handled by webservice handler service?

Is there a specific reason you don’t want to use the consumer alias?

WM pick up the settings from alias, the way SOAPHeader is constructed become very unpredictable outside the normal use cases. You may want to open a ticket with SAG for exactly what you want to achieve.