Webmethods.io SFTP Get file Not working on run

Hi,
So I have been trying to fetch file list from my sftp server, When i test the component it works fine and returns the first 2 files in the server, but on run it throws:

a5: Get List of Files and Folders: Permission denied to delete this file

The error message it self is weird as i am trying to get the files not delete.

And also it worked on the first run and stopped working in subsequent runs with the above error.

Thanks in advance for your help

Hi Vipin,
This kind of issue occurs normally when we have multiple threads are running in parallel.
When multiple thread works, each thread try to access the same file and because of this issue occurs.
Can you please confirm this.

Regards
Vikash Sharma

No there are no multiple threads running,
So the workflow starts with this SFTP call there is nothing that runs along with it

Hi,

  1. Can you tell us which datacenter are you using?
  2. Do you had delete action in your workflow?
  3. it will be great if you can share the logs for the workflow

Regards
Vikash Sharma

Hi, Sure so my work flow is pretty simple

  1. I get all files in a folder using the get files and folder connector,
  2. get each file’s content and upload it to s3.

There is no delete operation done anywhere, not in any other workflows too.

a5: Get List of Files and Folders: Permission denied to delete this file	

the above is the error, now i tried to execute it and it worked the first time and returned files, from second time it again gave the same error.