WebMethods Interaction with LDAP

Can someone explain me how webMethods Interacts with LDAP? is their any LDAP adapter that webMethods provides? what is the related documentation that one needs to read? help me Please

Thanks in Advance.

There are two ways the webMethods Integration Server interacts w/ LDAP.

  1. Services in WmPublic in the ldap folder - These Java services enable search, bind, update… For example, the services allow you to integrate a human resources application to Microsoft Active Directory. Read the Built In Services Guide for more details.

  2. You can use an LDAP server to define Integration Server users and groups. This is done through the Administrator under Users & Groups > JNDI Settings. Read the Integration Server Admin Guide for more details.


Thanks for the useful Information.I will read the related documentation and will post the questions if i have any.


we are using pub.ldap:lookup and pub.ldap:search to query the LDAP fpr getting the results but after getting the results i’m unable to use them in the further flow.I’m able to view them in Results.But unable to use those results further.Please suggest me regarding this.

How do you want to “use the results”? What do you mean by “unable to use those results further”?

There is nothing in your post to help anyone to answer your questions.

What I mean is actually when we use a JDBC adapter or notification we can use the results directly in the pipeline.But when coming to LDAP i think so the results are retrieved as Object(I think so) .What exactly mean is i’m able to view them in results panel.Then my question is how to use them in further steps.

Once you get the result set, it’s up to you , how are you going to use further. Since that resultset may have complex types (multiple data types) , you may need to convert using wM transformer services.


I have trying to get the new pub.client.ldap.search working, but cannot get results.

I’m simply trying to get the Result output to display said results (or anything, currently just blank).

I’m trying to target a Security Group called (no quotes) “My Security Group”.

The Filter string I’m using is DC=C800019,OU=NA-Lexington,OU=My Security Group

The Search built-in service does not throw an error, but just does not display any results (blank).

I’m using Object as scope (but have tried subtree and onelevel with same blank results).

I know the C800019 ID exists in the Group. I’ve also tried UID=C800019 and CN=C800019.

Can anyone send me some other values I should be passing using Search to find a UID/CN within a Secruity Group?