webMethods CI/CD setup using gitlab and jenkins

Hello All,
Need quick help on the build creation through jenkins.

I’m working on POC to implement CI/CD setup using gitlab and jenkins.

  1. I have created a pacakge using local server and commited the code to git lab.
  2. created a project in jenkins and written a pipeline script for build, deploy and test.
  3. I’m able to create a build but deploy step is failing.

deploy step: ant -DSAGHome=C:/SoftwareAG11 -DSAG_CI_HOME=C:/SoftwareAG11/common/AssetBuildEnvironment/sagdevops-ci-assets -DprojectName=wmdeploy1 -DbuildOutputDir=C:/SoftwareAG11/buildoutput -DrepositoryName=C:/SoftwareAG11/webmethods-sample-project-layout deploy

C:\SoftwareAG11\common\AssetBuildEnvironment\sagdevops-ci-assets\${workspace.dir}\ProjectAutomator\wmdeploy1DeploymentSpec.xml this is autogenrated when i ran the deploy step, it is validating with ProjectAutomator.xsd. The XML validating with xsd and it is getting failed.

[ERROR] [29 Aug 2023 13:44:17,525] (MainClass.java:readXMLToDOM:93)
[exec] Error validating XML with schema. Exception thrown unknown protocol: c
[exec] Error Code = -9
[exec] java.net.MalformedURLException: unknown protocol: c
[exec] at java.net.URL.(URL.java:618)
[exec] at java.net.URL.(URL.java:508)
[exec] at java.net.URL.(URL.java:457)
[exec] at org.apache.xerces.impl.XMLEntityManager.setupCurrentEntity(Unknown Source)
[exec] at org.apache.xerces.impl.XMLVersionDetector.determineDocVersion(Unknown Source)
[exec] at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
[exec] at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
[exec] at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
[exec] at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
[exec] at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source)
[exec] at javax.xml.parsers.DocumentBuilder.parse(DocumentBuilder.java:177)
[exec] at com.softwareag.webm.deployer.automation.MainClass.readXMLToDOM(MainClass.java:80)
[exec] at com.softwareag.webm.deployer.automation.MainClass.(MainClass.java:47)
[exec] at com.softwareag.webm.deployer.automation.MainClass.main(MainClass.java:240)

C:\SoftwareAG11\common\AssetBuildEnvironment\sagdevops-ci-assets\buildDeployer.xml:92: exec returned: -9

jenkins ABE git GitHub Deployer cicd

Hi Pradeep,

looks like it doesn´t like Windows pathes when using Unix-Style path seaprators.


Hi Holger,

I tried to pass the path manually as well, even though getting same error.