webMethods 9.8 Oracle JDBC Adapter Notification Issue

Hi,

Since few days, I met a JDBC Issue. The same described here :
http://tech.forums.softwareag.com/techjforum/posts/list/0/56517.page

Error :
[ISS.0137.0006E] Scheduler: Error initializing scheduler: [SoftwareAG][Oracle JDBC Driver][Oracle]ORA-00904: “RUN_AT” : identificateur non valide

My current environment is :
Windows 7
webMethods 9.8 :
IS_9.8_Core_Fix6.jar
IS_9.8_SPM_Fix1.jar
adapter-9.8.0.0.jar
adapter-api-9.8.0.0.jar

JDBC driver installed :
D:\SoftwareAG\IntegrationServer\lib\jars\ojdbc6.jar

Could you tell me why it happends ?

Do I need to install something (an new ojdbc driver) ?

Regards

This is happening since the last update operation i’ve made a week ago (with the updateManager).

Regards

Hi Cedric,

which Fixes did you apply exactly when running the Update Manager last time?

please check for latest SCG-DataDirect-Fix as well as for latest DCC/DBC (DB Configurator-related)-Fixes.

Apply these and migrate your database schema.

Regards,
Holger

For resolving which issue did you run the update manager ? Are you still get hampered by the issue ?

Thanks,

Hi,

No I still have this issue, but I was on hollydays few days before the support gave me a solution.
So apparently I need to run another tool to migrate the database (Database Component Configurator).
I’m going to read the documentation to find this tool…

Hello Cedric,

Good day to you. Thank you for logging Support Incident with SAG Global Support. My name is Shahbaz and I own the Support Incident.

Please provide the error screenshot.
Fix level using Update Manager.

"RUN_AT" is a new column that is added to IS_USER_TASKS table.

Please query IS_USER_TASKS database table and verify whether the RUN_AT column is present or not?

Please apply the latest Integration Server 9.8 Core Fix 6.

PIE-40119
When starting Integration Server after installing a fix that included PIE-36477 scheduled tasks are suspended and have a Next Run of 0.

PIE-36477
After transitioning to or from daylight savings time, scheduled tasks run twice or not at all.

Integration Server runs scheduled tasks based on the time relative to the time zone. This caused issues when entering and exiting daylight savings time, specifically tasks ran twice or not at all.

Now, Integration Server runs scheduled tasks based on coordinated universal time (UTC). Because Integration Server runs the tasks without regard to the relative time zone, the start and end of daylight savings time does not affect the execution of scheduled tasks.

Important! If you are using an external database for the ISInternal functional alias in Integration Server, after installing a fix that includes PIE-36477 and before starting Integration Server, make sure that the latest scripts for ISInternal have been applied to the database used by the JDBC pool alias associated with the ISInternal functional alias.

Update Manager will not migrate the Database Component and user need to run DCC (Database Component Configurator) for it.

[ISS.0137.0006E] Scheduler: Error initializing scheduler: [SoftwareAG][Oracle JDBC Driver][Oracle]ORA-00904: "RUN_AT": invalid identifier Above error occurred because IS scheduler service not able to find table field "RUN_AT" in IS_USER_TASKS [Table]. This is a new field which is newly introduced in newer version of Database (DB) component.
To resolve this issue, ISInternal DB component need to be update to the latest version For your information, the DB Component need to migrate to latest version after applied the IS Core Fix. This is mentioned in the read me.

Thanks & Regards
Shahbaz

Regards

hi,

Thanks to you the issue is finished, since I’ve executed the script from DCC.

Regards

Hello having the same proble,m can you please tell me what script di you use and were i can find it, fist time using DCC really dont now how to use this tool.

Regards From Argentina !!!

Hi German,

please migrate IS database (PRODUCT IntegrationSever) to latest version.

Which Fix did you apply to your IntegrationServer?

Regards,
Holger

Hello we installed IS_9.8_Core_Fix6, just found out were DCC is /softwareag/common/db/bin now we are trying now to migrate the Database Component and wih DCC

Regards

Hi,

In my case, I’ve updated the ISInternal Component of each of my database schemas.

Regards

Hi,

I was facing the same issue. Even after recreating the tables using dbconfigurator i was having same issue.

Then i updated the table IS_USER_TASKS manually and added the missing columns.
Now its working fine.

Regards,
Syed Faraz Ahmed

Hi,

this might indicate that your are missing the appropriate Fix for the database scripts containing this update.

This should mentioned in the readmes referring to the corresponding entry in those readmes.

Regards,
Holger

Hi Holger,

I have latest FIX IS_9.8_Core_Fix7 installed on my machine. Even then i was facing this issue.
I believe there is no update after this fix for now.

Do i need to install fixes for any other component as well like JDBC or so…
wondering if those fixes have effect on this one?

Regards,
Syed Faraz Ahmed

Hi,

When you’ve selected your component ISInternal (type Migrate) and executed the process, what was the reply ?
Did the tool display that all was ok ?

When I’ve executed it, he displayed my component was succesfully migrated.

Example :


  • migrate Database Component: ISInternal ISI

Supported migrations:

  • Migration: Oracle 55.0 to 56.0
  • Scripts: migrate
    
  •   Script(1): D:\SoftwareAG\common\db/scripts/oracle/isinternal/migrate/55_to_56/ora_isi_m_55_to_56.sql
    
  •   Script(2): D:\SoftwareAG\common\db/scripts/oracle/isinternal/migrate/55_to_56/ora_isi_m_55_to_56_dml_tracking.sql
    
  • Migration: Oracle 56.0 to 57.0
  • Scripts: migrate
    
  •   Script(1): D:\SoftwareAG\common\db/scripts/oracle/isinternal/migrate/56_to_57/ora_isi_m_56_to_57.sql
    
  •   Script(2): D:\SoftwareAG\common\db/scripts/oracle/isinternal/migrate/56_to_57/ora_isi_m_56_to_57_dml_tracking.sql
    

  • Executing script : D:\SoftwareAG\common\db/scripts/oracle/isinternal/migrate/55_to_56/ora_isi_m_55_to_56.sql
    
  • Executing script : D:\SoftwareAG\common\db/scripts/oracle/isinternal/migrate/55_to_56/ora_isi_m_55_to_56_dml_tracking.sql
    
  • Executing script : D:\SoftwareAG\common\db/scripts/oracle/isinternal/migrate/56_to_57/ora_isi_m_56_to_57.sql
    
  • Executing script : D:\SoftwareAG\common\db/scripts/oracle/isinternal/migrate/56_to_57/ora_isi_m_56_to_57_dml_tracking.sql
    
  • Executing script : D:\SoftwareAG\common\db/scripts/oracle/componenttracker/25/create/ora_ctr_c_dml_view.sql
    

MIGRATE ISINTERNAL [57.0] SUCCESSFUL

Then when I executed the action type “Catalag” he shows me the new version (55.0 before migration) :


Components successfully migrated

ISInternal 57.0

Regards

Hi,

you will need to apply at least DC_9.8_DBS_Fix5 (latest known is DC_9.8_DBS_Fix6) to have the right migration scripts available. This dependency is stated in the beginning of the Readmes for IS_9.8_Core_Fix5 thru IS_9.8_Core_Fix7.

After applying the fix to the installation rerun the migration using the Database Configurator.

Regards,
Holger

Hi,

Strange, I had DC_9.8_DBS_Fix6 installed in my machine. Even then it happened.
Anyways i will install the latest fixes today and let you know…and the latest fix available for Database configurator is DC_9.8_DBS_Fix8.

Thank you for your reply.

@Cedric: Yes i got success message when i ran the scripts.

Regards,
Syed Faraz Ahmed

Hi,

in this case Fix8 (as well Fix7) was not properly visible under Recent Articles → Recent Fixes as I am checking this on a regular basis and keep a copy of the Readmes for reference.

The last readme I had available was that one for Fix6.

Regards,
Holger