webMethods 9.5 upgrade from 8.2 - SOAP response error (One or more required Headers ..)

Hello,

After the webMethods 9.5 upgrade from 8.2, we are getting the errors (One or more required Headers “urn:enterprise.soap.sforce.com:LimitInfoHeader” are not present in the SOAP response).

Regards,
Ravi

Did you get any fix from SAG or how did you make it work?

Hi Guys…,

We are facing same issue with couple of webservices, after upgrading to 9.5. Can you please let us know what is fix given by SAG. Appreciate your immediate response.

Thanks,
Bhanu

Hi Bhanu,

Meanwhile you get some replies (Fix details) from the community members, can you simultaneously work with SAG technical support regarding this error.

Hi All, we have worked with SAG for this issue & below is the response.

The error:
One or more required Headers “http://siebel.com/webservices:SessionToken” are not present in the SOAP response.

is resulting from the validation of the soap response. The wsdl you provided mentions the SessionToken as a required header. Check in your soap response if this header is included or not. Most probanly this header is missing which is causing the 9.5 validation framework to throw this exception.

There was quite a bit of refactoring between 8.2 and 9.5 allowing for asynchronous response handling and the response validation code had gone through several changes as a result of it. The current 9.5 response validation code is working as expected if it issues that error when a response does not contain the defined headers, the 8.2.2 code was in error if it was not issuing the error message.

At this point we are figuring out options, to modify the wsdl and re-import it or work with the source & target teams to check why they are not populating the required headers in response.

Thanks,
Bhanu

Hi Bhanu,

Did that solution/response given by SAG work for you? Is the header included in SOAP response? Can you let me know please.

Hi Bhanu/Mahesh,

I have also faced below issue in webMethods 9.5 environment after importing the consumer WSDL.

Resolution :- Create handler with the same QNAME and pass null header to the response service (auto generated response service in 9.5 environment) it will solve the issue.

NOTE:- In response service pls modify service signature with handler specification.

Let me know if you face any issue.

Thanks,
Yogesh

Thanks for sharing your input. :slight_smile:

Hi Yogesh,
I went through the workaround mentioned by you in for the validation error in WM95. we recently migrated to Wm95 from WM8.2

Could you please let me know how to pass NULL header to Response service ?

I assume the logic to pass NULL response Header should be in the ConsumerResponse Header Handler.

I tried to invoke “addHeaderBlock” by mapping its HeaderDocument field with New Document Variable with name same as the Header Name.

However I am still receiving the error "[ISS.0088.9443] One or more required Headers “urn:dummy.com:HeaderName1” are not present in the SOAP response.

Issue background:
As per the WSDL, the operation has two Header Fields. In some scenario/testcase --> The backend is passing only one of the Header Element in the Response.

The same Response is returned successfully in WM8.2. In WM9.5 the service is returning this validation error.

Thanks in advance !!!
-K.A.N