Web Service Descriptor Operation

What product/components do you use and which version/fix level?

Integration Server v10.11
Software AG Designer v10.11

Are you using a free trial or a product with a customer license?

free trial

What are trying to achieve? Please describe in detail.

Hello Everyone

I’m new to Software AG.
I have created a SOAP service descriptor and I’m trying to write the flow service implementation of one of the SOAP operations.
when hardcoding the results inside the flow service, the service returns the SOAP response correctly with the results.
but when mapping the results from a SOAP connector which calls another SOAP service successfully, the flow services itself returns the results correctly but the SOAP returns an empty SOAP body without errors
the hardcoded and mapped results looks identical when debugging the flow service including SOAP namespaces, but the former returns with SOAP response and the latter does not.

your help will be greatly appreciated.

Do you get any error messages? Please provide a full error message screenshot and log file.

no

Have you installed latest fixes for the products

yes

Are you dropping any output pipeline variables that have the same name?

Do post a screenshot of the invocation along with the pipeline mappings, so we can take a look.

KM

1 Like

thanks for responding.

here is the pipeline of the connector invocation (which successfully return the data):


connector_invocation_results

and here is the pipeline for mapping the invocation results to the response:

and here the empty SOAP response when calling the service:

as mentioned the previous post, when hardcoding the values the response will return successfully, but after the mapping something happens that somehow results in an empty SOAP response

Best Regards

I don’t see the “PersonResponse” document in your output screenshot, so I assume you executed the Connector (child) service only.
Do post the screenshot of the parent service’s execution output, which has the final mapping step.

Execute the parent service in debug mode, step through and investigate the output variables and mapping closely. For good design, you must add your final output variables to the service’s output signature tab.

KM

1 Like

Thanks for responding.

I actually did the debugging in the parent service but cut out the results.
Here is the full results of the parent flow service:
parent_results

I think the issue is that IS is somehow translating the parent flow service results (PersonResponse) into an empty SOAP body for some reason even though results exist.

I tried variable substitution instead of copying and I got the following results:

please keep in mind that “perform pipeline variable substitution” option was checked and the result was successfully copied during debugging.

I tried to look for how IS convert output results into SOAP body and what are the restrictions involved but I could find any related info in the documentation.

Best Regards

I haven’t looked at the code, but this seems like a bug, @John_Carter4.

KM