watt.net.proxyHost keep re-appearing

Hi

We are running Webmethods 7.1 on a mixture of Windows and Unix.

Every weekend without fail our Integration server running on Unix gets a proxy server set, but we do not know where this setting is coming from.

Every Sunday evening, we remove the proxy server setting so it doesn’t cause us any problems during the working week.

On occasions, every one of our Integration servers within the farm, gets the proxy server setting set…

The Unix box gets rebooted every weekend on a Saturday, and then we have a scheduled task that restarts the Integration server on a Sunday night, and it’s at this point we know the proxy server setting is set.

Whenever the MWS/Audit/Broker server has to be rebooted (for general maintenance and Microsoft patching etc…) all the Integration servers are restarted as part of that process, it’s at that point we see the proxy server set on “all” the servers in the farm.

This proxy server setting is for a server that did once exist, but was switched off some months ago, and it’s since then we have been trying to remove the setting… but it keeps coming back!

On the Unix instance, I did try various ways of stopping the IS (kill -9 and the normal shutdown script) and starting it back up to see if the setting appears, but I cannot force it to be set… so my conclusion from that, is that it’s not to do withe shutting down and starting up each weekend.

We restart one of our other IS servers each weekend, and this one does not get the setting (apart from when the main Audit/MWS box is rebooted…???)

Any help with this will be appreciated.

Thanks
Jason Harrington

There must be a startup service that is doing it.
Try to search this string “watt.net.proxyHost” in the package directory (including the content), hope you can find the service that is doing it.

Hi Tony

Thanks for replying.

I have looked at that already, in Unix running (from the package dir):
find . -exec grep -i proxy {} ;

Also, this doesn’t add up, because we have tried a restart late on a Sunday night (after a clean shutdown and after a kill -9) and the setting does not re-appear…?

Jason

try to search for:
wm.server.admin:setExtendedSettings
If it’s not a startup service, a remote system can call a local service to update the setting. But it needs to call this service to set it.

Hi Tong

Apologies for calling you Tony earlier…

Previously I was searching for the IP address in the find and not “proxy”, as it returned too many rows of data (and made my emulation go all funny), but I have just tried it again and it has pointed to 2 packages which are coded here which have a reference to watt.net.proxyHost.

So, I will now speak to our developers about these package and find out why they are referencing this extended setting.

Still not sure why it’s not getting set on every startup…!

Thanks again.
Jason