Using <xs:unique>

I am having trouble adding a schema to my database that utilizes the xs:unique element. The Schema Editor clearly allows me to add it within an XSD document. But, when I load it into Tamino using the Interactive Interface, I get the following message error:

- <ino:message ino:returnvalue=“7703”>
<ino:messagetext ino:code=“INOXDE7703”>validation has detected an error in document</ino:messagetext>
ino:messagelineINOXDE7740: Line 72, Column 47: (cvc-complex-type.2.4): element child error [element “xs:unique” in element “xs:element”]</ino:messageline>

Tamino can’t only allow TSD-type documents into the Data Map, can it?

Please help.

Thanks in advance,


Tamino allows only those schemas that confirms with the TSD schema specification.According to the TSD specification the schema cannot have xs:unique element.So if you want to use your schema containing the unique element then you have to first transform the schema so that it confirms with the TSD standard.

Steps for transformation :
1.Open your schema in schema editor. to Tools/Transformation/All At Once menu item
3.Select the target TSD version to TSD4.2 the finish button.

The transformation makes the schema TSD4.2 specification compatible.Now you could define the transformed schema to Tamino.



yes, in fact Tamino does not allow the full range of XML schema to be defined. The Tamino Schema Editor has the capability to convert an XML Schema to the XML schema subset allowed by Tamino




Thanks much for your assistance on this. Unfortunately, in my Schema Editor (v4.1.4.2) I don’t have the option Tools->Transformation->All At Once. I only see the following:

Tools->Transformation->Replace with group content
Tools->Transformation->Replace all group references
Tools->Transformation->Make local
Tools->Transformation->Make global

Tools->Transformation->Convert To->All
Tools->Transformation->Convert To->Choice
Tools->Transformation->Convert To->Sequence

These appear to be functions for transforming “parts” of my document, not the document as a whole into a TSD4. At least, that’s how the documentation explains it as well.

And the even worse part is that those options are all greyed out – all disabled – for all parts of my XSD, no matter where I click in the document I can’t enable them. I am using the Tamino Eval through the XML Starter Kit. Does that make a difference in the capabilities of my shema editor?


Dr. Sch