Using Subversion as VCS for webMethods

We’re implementing a VCS using Subversion with webMethods. We’re currently running IS 6.5 SP1 on Solaris and Windows boxes. We’ve chosen to go the route of versioning artefacts at the element instead of the package level. The main reason is that we will have some users working directly on our shared developement IS and others working on a local IS. This way we can at least try and detect conflicts that may arrise. (It’s not exactly elegant I know but there’s politics in play).

Anyway I’ve set up scripts that allow us to work this way but I’m having problems activating packages that have been updated and contain .svn folders. On the Windows boxes it works fine - we can update a package out of SVN, the scripts activate the package through some flow service calls and away you go. However when doing the same on the Solaris machines the package activation seems (whilst the admin console reports all is ok) to fail. The strange thing is the IS actually goes and deletes all the flow.xml files from the file system. Weird!

I was just hoping someone might have had some experience with going down this track before. I know it’s possible to change the directory names used by the SVN client (like _svn for a change) but that requires recompiling the client and it would be neater to leave the client unmodified.

Alex,

Have you taken a look at the webMethods VCS module introduced with 6.5 SP1? This provides standard VCS support out-of-the-box with check-in/check-out directly from Developer. Initially only Microsoft VSS is supported, but Subversion support is available using the Subversion package released as a sample on Advantage:

http://advantage.webmethods.com/article/?id=1614009767

regards,

Jonathan Heywood
webMethods (now Software AG) Professional Services

Hi Jonathan,

where do we find more information on using webMethods with Subversion. We have a couple of problems, i.e.

I. How to set the working directory ?
II. Are username and password passed to the cmdline when submitting subversion requests ?

Thanks a lot
Frank

Frank J Langel

I am tring to integrate SVN in IS7.0. I have installed subversion through apache web server. It is working for other projects. I tried to install WmSubversion package in IS7.0. Still I dont’t understand how to configure WmVCS to access Subversion repository. Could somebody explain how to configure Subversion in IS7.

Regards
-Segar

Software: Integration server 6.5 (windows), Subversion version 1.4.4 r25188 (linux redhat ES 4) running on Apache 2.0

Problem description: IS is configured as described in the document VCSIntegrationDevGuide.pdf. Menu for VCS

Hi,
I experience the same problem.

I support the request of Segar above, to resolve this Issue.

Package Name

Segar,

What you are seeing is a known issue with the current WmSubversion package and is being worked on.
Expect to see a new release of WmSubversion hitting Advantage quite soon.

regards,

Jonathan

Pleace look into delete command also. It also gives an error. But it seems to me that it deletes the file however. The error message is misleading.

-Segar

Is the WmSubversion which was posted 15 days ago the updated one?

I am still experiencing problems like the trying to save new services before its done an “add” as described above.

thanks

Louis

Hello again,

I have been testing the subversion package for the last two days. It still not working as mentioned by Louis. This time the package did have source code with it. I debugged the code and found two bugs which are relatively understandable. Fixed the code locally and tested it.

I could also fix the javaservice bug regarding subversion. The error occurs due to wm tries to lock the files again and agian. When it comes to the second time it hangs and goes to timeout. I fixed it locally and tested.

  1. java file: SubversionClient.java

Hello Segar,
Could you please tell me how you built the source again after fixing these bugs ?

You just use jcode.bat to generate the class files. Like

jcode fragall WmSubversion

Reload the package afterwords.

At this stage we are using the modified WmSubversion package to version control the webmethos code.

There is one issue which to us is a minor one. When you try to delete an empty package it gives an error. My goal in fixing these bugs is to do minimum changes in the existing code. The method which involved in this bug is

protected static boolean directoryWillBeEmpty(File dir, Collection filesBeingDeleted) in SubversionClient.java

As I need more time to do the analysis work in the code to fix and test it, we just put a side this bug. But this need to be fixed.

There are still some issues regarding the use of subversion as a version control system in webmethods.

I’m also running into problems creating an MQ adapter service from developer.

Hi all,

we are planning tp use Subversion for versioning IS Services but are encountering problems having more than one IS connected to the same Repositoriy. Are there any experiences / recommendations connection several IS to the same Subversion repository.

Problems encountered so far:

WmSubversion places a lock on the services checked out but those are not evaluated at checkout time, so several people may work on the same source. When checking in again, all but the first who checked out get an error. As checking in or mering is not possible fpr the later checkouts an error right in the beginnin, when trying to chekcout a locked service would be preferable.

When trying to check in in a service locked by another user the check in fails however the lock in Developer is released. Revert is nout possible and any try to update to the latest version of the reposioty fail with an error “service already checked out”. Cleanup requires action on the server side using svn tools, but server side is usually not accessible for our developers.

.svn directories may cause problems when deploying, especially between Unix and Windows. Deployer does not offer to exclude files from builds. Any ideas there?

Thanks in advance for any inputs on this topic.

Martin

Hi, we are trying to configure sub Version with webmethods 9.
The Repository location sis not being recognised and we are getting the follwoing eror messages:

Caused by: com.webmethods.vcs.VCSException: [ISS.0132.9117] error running command [svn, mkdir, --username, wM9, --password, , -m, Initial Import, https://:5555/Repositories/packages]; exit value: 1; output: [svn: E120171: Unable to connect to a repository at URL 'https://********:5555/Repositories’, svn: E120171: Error running context: An error occurred during SSL communication]
Here. Repositories is the SVN repository directory in F drive.

Can some body pls give an eample of how the URL pattern should be ?

Thanks,
Priya