using LDAP authentication

Hello,

I have tried to configure X-Broker to use LDAP Authentication. I followed the documentation and edited the ldap.xml and broker-config.xml files but it looks like my custom adapter is not called when the request comes to the Broker. I also created the jar file with the adapter and placed it in the right folder (also updated the classpath); configured X-Registry policy to use LDAP authentication. But nothing works. How can I make sure my adapter is being called?

thanks

Hello,
Here are a few pointers, to help you find why the adaptor is not being called.

  1. Make sure that the policy contains a Consumer Identification assertion. The Consumer Application is supposed to be configured with either HTTP/WS-Sec user tokens.
  2. have a look at the policyenforcer.xml present in {X-Broker.HOME}/resources folder; it should contain SecurityNegotiator for the configured contract service.
  3. The Security Mode in xbroker-setup.xml should be switched to Custom, i.e. Default Security Mode should be set to false and Custom switched to true.

Hope the info helps.

Hello,

Thanks for the response. Actually - I do have all these things setup and still experience the problem. Let me describe exactly what I have (I am trying now to use Sample Adapter instead of LDAP). The goal is to see this adapter called from X-Broker.

  1. My policy contains CI section that is the first of the assertion list.
  2. in the CI assertion i have set “IsAnonymousAllowed=false”
  3. The next assertion is “Sample” that I have created as my custom assertion template.
  4. In this ‘Sample’ assertion I have one string as input (for a test purpose)
  5. my consumer application is configured with WS-Security and the user name is set to ‘user123’.
  6. policyenforcer.xml does contain the information about my contract: (
    CINegotiator

    )
    ^^^^^ Is this correct setup?
  7. the security mode is set to custom the way you have described in xbroker-setup.xml file.
  8. in my adapter class I have the log messages (just for testing)
    log.debug("******* test ****");
  9. I don’t see this in the log file.
    so the question is - what else I am missing?

thanks

Can you try just one more thing with your original setup.
Please add a soap-actor attribute with the value “http://com.infravio.broker/security” in the Security Header.
It should look something like this after the addition:
SOAP-ENV:Header
<wsse:Security SOAP-ENV:actor=“http://com.infravio.broker/security” wsse:mustUnderstand=“1” xmlns:wsse=“http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd” xmlns:wsu=“http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd”>
<wsse:UsernameToken wsu:Id=“SecurityToken-0”>
wsse:Usernamewsuname</wsse:Username>

Thanks, it did help! I can see that the custom adapter is being called. For some reason there is an exception in the log file:

21 10:22:08 EDT 2007
ERROR - EventDelegator - java.lang.ArrayIndexOutOfBoundsExceptio
n: 23
INFO - Adaptor - ************* in custom Sample Adaptor
process() ****************
WARN - Adaptor - ************* in custom Sample Adaptor
process() ****************
INFO - Adaptor - Creating dir ** resources\

I am not sure if this is important one or not.

thanks again

Hey,

I tried to implement an LDAP Authentication against Windows Active Directory for testing under webMethods 7.1.

After solving some problems there still is an issue when I try to add some LDAP Users to Roles etc. Each time I try to add some, my mayWebmethods Server crashes.

Adding to it there is no chance to authenticate because of the same problem. Each time I try to logon, my MyWebmethods Server crashes. With Integration Server there is no problem.

I succeeded in searching for users in LDAP etc but adding and authentication does not work. Can someone help me

Thanks Martin