URL Alias with path variable


I’m currently exploring the API Gateway particularly in creating URL Aliases. My current IS version is 10.1.

This is my goal, I want to mask the URL of my API


Here are my challenges,

  • I created an alias in the API Gateway UI but the alias doesn’t take effect. So, I went to the IS of the API Gateway and add the URL Alias there. After that the URL Alias works.

  • When having a dynamic variable path in my URL, the varPath is treated as if its part of the URL Alias, Hence the API Gateway returns

Object Not Found ( /resource/testVarPath)

where “testVarPath” is the variable Path for my API.

Please help :slight_smile:


Upon Exploring, i found this article that solved my problem:

I just have to add the extended setting

Hello Jay Mark Domugho

I would like to delete the “/gateway” in the URL: https: // apigatewayhost / gateway / myApiName

I want to hide the URL of my API:

http: // /gateway/myApiName
http: // /myApiName

I tried to follow the same procedure as you, creating an alias and changing the watt.server.url.alias.partialMatching parameter to true, but the call is still done via the old URL.

Do you have an idea about that?

Thanks in advance