Urgent! very urgent! please help

X-Application Version: 3.1.3
Tamino Version :
Platform : Win2k Prof.
WebContainer : Tomcat 3.3
JDK Version : 1.3.1

<xapp:display select=“url_link”>
This is the link

If my “url_link” contains “&”, say for examples, “http://xxx.com/xx.asp?a=b&c=d”, the above code will produce


which is absolutely wrong url!


maybe above is not clear, the html source show


, rather than only a single “&”

sorry, it’s still not clear, sorry,
the html source (by view source) is


there is a “&”, plus 2 “amp;”, which make the url not valid,


If you don?t want content of a node is encoded, the attribute rawcontent could be useful. Try out

<xapp:display select="url_link" rawcontent="true">
<a href="{0}" target="_blank">This is the link</a>
</pre><BR><BR>Another thing we found out: in contrast to attributes JSP tags it is allowed to have JSP tag within the content of an HTML attribute. You can write your JSP code<BR><BR><pre class="ip-ubbcode-code-pre">
<a href="<xapp:display select=?url_link? rawcontent='true' />" target="_blank">This is the link</a>

Depends on your taste what kind of code you prefer. If you have still problems with the encoding also when using the ‘rawcontent’ flag, send another post and I will try to reproduce the problem and look for a fix.


Hi Christian,

putting xapp:display/ inside href solve the problem. :slight_smile:

but my taste would be putting inside xapp:display </xapp:display>, becoz it look more tidy, don’t have “<” inside “<”, won’t crash my html page if view by some html editor. adding rawcontent=“true” won’t help, it still encoded my link.

I will use that quick work around before a solution comes out. thanks!



did you try out also the ‘rawcontent’ flag with the version where you encapsulated the a tag?

<xapp:display select="..." rawcontent="true">
  <a href="{0}">...</a>

It should work also. If not, I have to check this behavior. It would be a bug.


yes, it does not work

<xapp:display select=“url_link” rawcontent=“true”>
<xapp:display select="/title"/>