Updgrade jvm 1.3.1 to 1.4.2 for IS 4.6

Following this alert from WM :

‘webMethods has identified an issue that may cause your webMethods
implementation to cease functioning on May 18, 2006. A thorough analysis of
the webMethods software suite has been conducted and you are being notified
as one of our customers who may be subject to this problem. Please log into
webMethods Advantage http://advantage.webmethods.com/critical for more
information on the issue, effected webMethods components and most
importantly, how you can keep this issue from effecting you.’

We may consider to upgrade the IBM jvm 1.3.1 currently running for IS 4.6 to 1.4.2.
However, reading the installation instruction for IS4.6, I have no clues to predict if IS 4.6 is comptatible with jvm 1.4.2 although it says that it supports jre 1.2.2 and later.

Does someone has experience of running IS 4.6 on IBM jre 1.4.2 to share.

(As we are running on IS 4.6 I am not even sure that we are affected by this issue, but as we are running IBM JVM 1.3.1, I started this thread in case of).

Big thanks in advance.

I am working on the same issue…
Any help?

BTW, should not this be posted under forum –
Managing webMethods Integration Server ?

  • NS

Hi All,

I am facing a problem, while looking for this issue.

We have many different environments for webMethods. For some of them, I could not even locate for the ibmjcefw.jar file under lib!

For some instances, I could locate that lib (6.1) and when I looked into that jar and found the manifest file, there is no entry for “ibmjcefw.jar”!!

If anybody has worked on this, Please help in locating the problem.

Thanks,
NS.

Hi Marks

Thats really very informtive, thanks.

Cheers
Jeevan

Hi,

We are getting this error during IS6.1 on windows2000 startup on May18th 11:34PM…So i guess this error related to above mentioned JVM issue???

Both our QA,PROD servers are down at this moment.

java.lang.NoClassDefFoundError: javax/crypto/f
at javax.crypto.Cipher.getInstance(Unknown Source)
at com.entrust.toolkit.security.provider.X917Random1.<
ce)
at com.entrust.toolkit.security.provider.X917Random.<i
e)
at java.lang.Class.newInstance0(Native Method)
at java.lang.Class.newInstance(Class.java:262)
at iaik.security.random.SecRandom.a(Unknown Source)
at iaik.security.random.SecRandom.getDefault(Unknown S
at com.wm.app.b2b.server.StateManager.init(StateManage
at com.wm.app.b2b.server.Server.run(Server.java:248)

Please advice.

TIA,
RMG

Yes, I think it is.

Thanks Mark,

All right we solved the problem,here is what we did reference from advantage.

We edited the server.bat and changed this line
SET JAVA_DIR=C:\webMethods6\IntegrationServer\jvm
to
SET JAVA_DIR=C:\webMethods6\jvm\win142

Save it and restart the server.It worked great…

HTH,
RMG

hi, i m running wM 6.1 on windows XP pro sp2…it used to work fine…but yesterday when i started IS, it does not…the error msg is as posted in similar threads…

java.lang.NoClassDefFoundError: javax/crypto/f
at javax.crypto.Cipher.getInstance(Unknown Source)
at com.entrust.toolkit.security.provider.X917Random1.(Unknown Sour
ce)
at com.entrust.toolkit.security.provider.X917Random.(Unknown Sourc
e)
at java.lang.Class.newInstance0(Native Method)
at java.lang.Class.newInstance(Class.java(Compiled Code))
at iaik.security.random.SecRandom.a(Unknown Source)
at iaik.security.random.SecRandom.getDefault(Unknown Source)
at com.wm.app.b2b.server.StateManager.init(StateManager.java:63)
at com.wm.app.b2b.server.Server.run(Server.java:248)
so…this z what i did…

  1. changed system date to one year previous date(05/26/2005) and rebooted the system and started IS without making any changes in my server.bat.
    result:did not work…
    2.i changed the system date back to the original…then edited server.bat
    entry to this
    SET JAVA_DIR=C:\webMethods6\jvm\win142\jre
    alternatively(or)
    SET JAVA_DIR=C:\webMethods6\jvm\win142
    saved the file and started IS 6.1 from Command console…
    Result:this time it partially loads packages and after a while aborts…
    the IS could not start…
    Now what should i do?

A.should i go to SUN website and download JRE 1.4.2 …where do i keep the downloaded file(Path)…
can someone give me detailed steps…installation etc…any class_path settings or Path settings to make along with this…

B.should i download JRE 1.3.X(sun) along with another patch mentioned therein and follow the same procedure as in step A above…

C.i m not downloading from IBM site since i understand they are not supplying patches for NON-IBM OS…anymore.
Correct me if i m wrong…

Any help with this is highly appreciated.

Thanks

Since this server is using XP Pro, I’m guessing that it is a development environment. If so, why not just reinstall the latest version of IS 6.1 from scratch into a new folder and copy over your custom packages.

You did not say what errors were occuring when you attempted to use the webMethods-supplied Sun 1.4.2 JRE. Understanding those messages might lead you in different directions.

Mark

Dear Mark,

Thank you for your immediate tip.Actually, i observed those errors i mentioned when i pointed to java JRE 1.4.2 were instance abort messages when i aborted the running server.bat instance.
what actually happenned is, afer loading packages, the instance never finishes…i mean the IS never starts…
i observer these…
1.previously when it was alright, the server.bat was consuming(MEm usage) around 300MB Ram(ctrl+alt+del).but now after i pointed
java_dir in server.bat to \jvm\win142, the server.bat process
consumes only 170MB Memory…The IS never starts…
and i wait more to see what happens…i find this…
Now the server.bat process is only using close to 30+MB mem and nothing
happens…i m at my wits end…

Any help is greatly appreciated…btw do u think SUN jre 1.3.1 will help?

Thanks again

Crank up the logging verbosity by starting from the command line with server.bat -log none -debug=6. See what errors are shown.

Mark

Dear Mark,

Thanks a lot again.u guided me in the right direction.i just got jitters with this JCE EXPIRY issue for no good reason and pointed to wrong port(IS).
SET JAVA_DIR=\jvm\win142\jre…works fine.
my IS is up now…i m sorry to have wasted ur time for all the wrong reasons…