UpdateDelete Adapter Notification problem

I am running Developer 6.1 and am interfacing with an AS400 (DB2) using a JDBC Adapter. I have created a Delete and an Update Adapter Notification. The Base name is ADPOHDlt, which has designated the Buffer, Trigger, and Sequence names WMBADPOHDltbavc2rx, WMTADPOHDltbavc2rx, and WMSADPOHDltbavc2rx respectively. When I schedule and enable the Polling Notification, I get the following message:
[ART.116.3038] Adapter Runtime (Notification): Error in Notification Callback:enableCallback notification KBSAquitecInterface.adapters:ADPOHDeleteNotification.
[ADA.1.316] Cannot execute the SQL statement “INSERT INTO TWCSSF.WMSADPOHDltbavc2rx VALUES( ‘WMBADPOHDltbavc2rx’, 1)”. "
(55019/-7008) [SQL7008] WMSAD00001 in TWCSSF not valid for operation."
[SQL7008] WMSAD00001 in TWCSSF not valid for operation.

I have tried changing the Base name to simply PH with the same results. Where does the WMSAS00001 come from? Should it not be WMSADPOHDltbavc2rx? I believe the userid connecting to the AS400 has sufficient security access.

Any advice is greatly appreciated.

LMH,

Make sure that AS400 user has sufficient priviliges/access on the Schema/table trigger, synonyms, resources etc…especially when you do Notification on the table,then only the AdapterNoficiation will be enabled.we have faced similar problem with Oracle.

HTH,
RMG.

Were you able to resolve this issue? If so, could you please post what you needed to do to get it to work. We are experiencing the same problem.

Thanks!

I believe the permissions are sufficient. I have tried to execute the Insert statement, by logging onto the AS400 as myself. I was unable to insert to a file that did not exist. I have noticed that the separator between Library and file is a period rather than a slash and compensated for that in my testing on the AS400. The DataSource Class that I am using in my adapter connection is “com.ibm.as400.access.AS400JDBCDataSource”. Is there another I should be using? Also, the file names on the 400 are limited to 10 characters, and I have tried having no Base Name on the Notification. Again, no success.

We are also facing the same problem

Were you able to resolve this issue? If so, could you please post what you did to get it to work.

Thanks!

We found and used a work-around, as we were unable to resolve the problem. We created triggers (one for update and one for delete) on the file, which would call a program to write the information to new files - again, one for update and one for delete. In WebMethods, I created Basic Notifications to monitor the new files, process the records, and delete them when finished. Hope this Helps.