Unable to start DBAdapter

I’m not able to start DBAdapter, whenever I attempt to restart the DBAdapter, the broker is also disconnected. The error message below. The DBAdapter has been configured and running well all along. Any advice?

Error Message :
Task: Update infosets:
Could not save infosets of event type “AdapterConfig::MyDBAdapter”
:Connection Closed (103-1070): The connection is closed.

Because of the errors shown above, this adapter cannot be enabled! You can only save this entry without enabling it.

I’m getting this error, too. I’m trying to connect to an Oracle database. Are u doing the same? Anyone can shed light on this prob? We are now trying to use JDBC adapter to see if we get the same problem. Have u tried using JDBC?

BTW, tnsping, sqlplus all work fine for us but not the DBAdapter. :frowning:

Do you get the same error message?

I’m also connecting to Oracle Database, using Oracle Intelligent Adapter.

It’s not the database problem therefore you’re able to tnsping your database.

I figure out that it’s may be the components that was configured in the EI that corrupted the DBAdapter, but since now the DBAdapter can’t be restarted, there’s no way to undo any changes.

well, for my system, its a fresh Broker, we only have defined document types. there’s another adapter (FileIO) that’s working fine. The Oracle Intelligent Adapter is the only other adapter configured.

I’ve contacted support and they suspect that is a version (service pack) issue. What is ur enterprise server version? Mine is 5.01 with SP7. Is it the same?

Hi, we’ve solved our problem. I’m not sure if it is the same issue but here it is:

In Adapter Config, for the Oracle adapter under the Java tab the field ‘Add to library path’ needs the //lib path specified. In our case, this is:


A more permanent solution (rather than doing it for each adapter) is as follows:

Login as root

/etc/rc3.d/S50adapter40 stop

Edit S50adapter40

At the top add:


Save the file S50adapter40

/etc/rc3.d/S50adapter40 start