Unable to locate or start Compiler

Hi All,

Whenever I try to compile a Java Service, I get an exception “unable to locate and start compiler”. I have downloaded jdk1.3.1 and placed it in C directory where the Integration Server is loaded. Then I have edited the server.bat file by commenting the path originally given and set the path as C:\jdk1.3.1_08. Now I am able to compile my Java Services. But the MAIN PROBLEM is after changing the batch file settings to the new settings, I am unable to bring the server up as an NT service (from the control panel). I HAVE to start the server from the command line. So please help me as to how to start the server as an NT service. I am using Integration Server 6.0.1 and Developer 6.0.1

Any help will be greatly appreciated.
Thanks,
Lavanya

Hello Lavanya,

Instead of changing the server.bat, change the server.cnf to

watt.server.compile=…/jvm/win.sun13/bin/javac -classpath {0} -d {1} {2}

here, the path can be the relative path to your jvm. Moreover this would be used only during compilation.

  • Rajesh Rao

Hi Rajesh,

Can you tell me where is that server.cnf file? I guess it is in IntegrationServer/config. But that shows a Speed dial property. How can I edit that? Is it with ws ftp? I have downloaded ws_ftp. But I am not understanding how to use it. Can you pls…let me know?
Thanks,
Lavanya

Hi Lavanya,

  select speedDial,Right click on it select send to to either 

text pad or note pad.Change setting or open Admin page.Click on
Settings—>Extended—>click on edit settings.Then change it.

–SriniK

Hi Srini,
But when I right click on that Speed Dial I get an option Send to and when i click on that i have only Floppy,Desktop,mail recipient and My docs. I cannot see any textpad or notepad…
Please help me…!
Thanks,
Lavanya

Lavanya,

You can get by without making any changes. Just add the JVM’s bin directory (where the javac.exe file is located) to you PATH (not classpath). Make sure you add it to the global environment variables. Then restrat your server and you will be able to compile your java programs.

Hi Lavanya,

PL download textPad trial version .It automatically visible to you. 

Otherwise open Admin browser click on extended tab in Settings button
click on EditForSettings tab change watt.server.compile field as
Rajesh mentioned above.DownLoad textpad from downloads.com

—Srinik

Hi Rupinder,

I have added that JVM to the environment variables and restarted the server. But I am still not able to compile my java services.
What to do?

Lavanya

Open notepad, drag and drop speedDial file into that.

NN

Hey Srini,
In the Admin Page I have only these:

watt.server.auditDir=audit
watt.server.auditGuaranteed=true
watt.server.auditLoadSchema=false
watt.server.auditLog=perSvc
watt.server.auditMaxMsgSize=4
watt.server.auditMaxPool=10
watt.server.auditMinPool=1
watt.server.auditRetryCount=3
watt.server.auditStore=database
watt.server.auditThreshold=100
watt.server.xref.type=jdbc

There is no watt.server.compile…
not what to do?
pls…help…
thanks,
Lavanya

Hi lavanya,

     Please you can able to type  

watt.server.compile=…/jvm/win.sun13/bin/javac -classpath {0} -d {1} {2}
then save it.If you click on EditExtendedSettings

—Srini

Hi Lavanya,

If you open server.bat using notepad/textPad 

Pl setup SET JAVA_DIR=C:\jdk1.3.1_04.Here I setup my JDK1.3.1_04 in
C drive.I downloaded JDK1.3.1_04 from sun site.I specified that path.This Rupinder mentioned earlier.Make sure that path setting
in controlPanel---->system---->open---->click on Environment—>
path value is C:\jdk1.3.1_04\bin;(This is my case).check your Jdk.

—Srini

Thanks Srini,

It worked.

Lavanya

Hi Lavanya,

    These are different ways.Which way you followed? 

----Srini

Srini,

If I set the path in the environment variables then it is not working. I changed the extended key settings in the Admin page and this worked. So I need not download Jdk anymore. With webmethods JVM itself it worked.
Thanks,
Lavanya

I am sorry for not providing the details. A server restart will not do the trick. You have to shut it down and bring it up again.

And if you are running the server from the commandline then make sure that you close the commadn window that you ran it from and then bring up another one and then start the server from that. Environment variable changes do not reflect in open Command windows.

I am assuming that you are using windows as you mentioned C drive in one of your emails.

Hi Rupinder,

Will surely try that way and let you know.
Thanks for ur help.
Lavanya

This is what did-not-work for me:

  1. Editing the server.cnf file, setting the watt.server.compile property to point to my javac.exe (with a server restart)

  2. Editing the server.bat file’s JAVA_DIR to my jvm’s top level directory (with a restart)

  3. Editing my desktop’s “Path” env variable and restarting my IS.

This is what worked for me:

  1. Adding the above mentioned watt.server.compile property using the admin console’s “Extended Settings” page.

Based on the above behavior, it appears that the watt.. properties defined in the server.cnf are different from what show up under the “Extended Settings” on the admin console. Also, none of the watt.. properties listed in the server.cnf show up on the admin console.

Will,

All the “Extended Settings” will be inturn accessed by server.cnf during server runtime.

HTH,
RMG.

in ISAdmin page,follow these steps to add watt.server.compile settings

goto ‘extended’ link under ‘settings’ section
if property is visible the edit it otherwise goto ‘show and hide’ key links
select the property to make it visible and then edit it