Unable to create new native thread

Hi all,

I’m trying to publish some package into another IS and I’m receiving the following message “unable to create new native thread” after trying to send the release.
I’d like to know what is going wrong, since IS has available threads and enough free memory.


I am getting the same error message " Unable to create new thread" while attempting to enable the JDBC connection. I am getting the full error message as below:

Error encountered

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource cus.source:jdbcConn_localTxn
[ART.118.5036] Adatper Runtime (Connection): Uable to configure connection manager.
Unable to create new threads

Does anyone have any idea on this error message and how to fix this problem permanently? It seems happen quit often to me. I am using webMethods 6.5.2 version.

Appreciate if someone can help.



i think you are running of the memory on the server…

Let me guess 32bit OS possibly very high java Hype size.

Try reducing the java MaX hype size and it will work…

I am having same issues however i need more of java Heap memory.

There are many reasons for getting this error.

  1. Your IS is producing lot of thread and not able to kill it. This can be for many reason like stateful session created by HTTP call, no time out in FTP session, JDBC using lot of connection or IS is getting more request then its capable of handling it.

  2. if on Unix system max_thread per process parameter is very low, you are sure to hit this error. Only way to fix is to restart the IS or increase the value of max_thread_process kernel paramter to a higher value. Generally default is 256 which is not enough in case of large integration.

If your parametres are not default or JVM tuned already then its good to get java core dump and analyse which service is creating threads and not able to release it.


Yes i see the same err, and below are the settings that I use:

set JAVA_MIN_MEM=1229M
set JAVA_MAX_MEM=1229M

Do you suspect anything wrong here?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.