Unable to create adapter services with JDBC adapter

I am unable to create adapter services using one of the JDBC oracle adapter. When i attempt to create SelectSQL, the eclipse becomes unresponsive only to have it terminated through task manager. However, the customeSQL adapter service gets created without any issue.

Anyway we could log the error so that we know what is the exact issue?

Additionally, the JDBC adapter connects Oracle database

However, if I use adapters which connect to other oracle instance, then the adapter services get created without any issue.

What is your IS/Designer version that you are dealing with?

Also if the customSQL template works fine then any other template should work fine connecting to the Ora 11g. Is the issue happening to continue even after the Designer restarts or differrent behaviour?

Please take it to your IS admin (Internal)as well and troubleshoot it.



First is to check at the Designer error log, see if you’ve any error logged there. To find out where the file is, go to Designer > Help > About then just follow the instruction there and somewhere you’ll see a button telling open error.log. Check for the timestamp where error happened, and see if anything suspicious.

Beside that on the server sider, you may also increase the logging level for server logger to TRACE for most of the Adapter Runtime and JDBC Adapter related subsystem. Execute the JDBC Adapter service again and the detail logging will be logged to server.log. Check in the server.log and see if you see anything suspicious.

I have restarted the designer multiple times, but still the same result. Additionally, I see the wm.art.metadata:resourceDomainLookupValues stuck under the service usage section.

Below is the log data under server logs -

[9]2019-12-05 09:21:59 MST [ADA.0001.0108T] Look up the resource domain “com.wm.adapter.wmjdbc.services.Select” : “tableNames”.
[8]2019-12-05 09:21:51 MST [ADA.0001.0108T] Look up the resource domain “com.wm.adapter.wmjdbc.services.Select” : “schemaNames”.
[7]2019-12-05 09:21:49 MST [ADA.0001.0108T] Look up the resource domain “com.wm.adapter.wmjdbc.services.Select” : “catalogNames”.
[6]2019-12-05 09:21:49 MST [ADA.0001.0108T] Look up the resource domain “com.wm.adapter.wmjdbc.services.Select” : “supportedJavaTypes”.
[5]2019-12-05 09:21:49 MST [ADA.0001.0108T] Look up the resource domain “com.wm.adapter.wmjdbc.services.Select” : “whereParameter”.
[4]2019-12-05 09:21:49 MST [ADA.0001.0108T] Look up the resource domain “com.wm.adapter.wmjdbc.services.Select” : “QueryTimeOut”.
[3]2019-12-05 09:21:49 MST [ADA.0001.0108T] Look up the resource domain “com.wm.adapter.wmjdbc.services.Select” : “MaxRow”.
[2]2019-12-05 09:21:49 MST [ADA.0001.0101T] Connected to database on “server_name” with “NO_TRANSACTION”.
[1]2019-12-05 09:21:48 MST [ADA.0001.0115T] Info: “Value of Catalog Separator : ‘.’”


please provide wM version as well as JDBC-Adapter version together with Fixes applied for:

  • WmART
  • WmJDBCAdapter
  • ServiceDevelopment section of Designer

Which version of the ojdbc.jar are you using?


we are using webM 9.10 version.

I have attached fixes for WmART and WmJDBCAdapter package.

Where can I find fixes to the Designer?


Hi Ruturaj,

please update your JDBC adapter to current fix (Fix18 ist currently the latest one I know of) as well as ART to Fix4.

Fixes for Designer can be listed in the UpdateManager.
Check for ServiceDevelopment entries.


I am seeing the below error in the Designer.

java.lang.reflect.InvocationTargetException Details in error log.

Hi Ruturaj,

InvocationTargetException usually means that the jvm tries to invoke a method on a class which cannot be found in the class.

Can you provide the stacktrace from the error log as this should indicate what is tried to be invoked?

Additionally make sure that the Fixes for the common libs are in sync between IS and Designer installation.