UM Port Issues

Hi Team,

I have changed UM default port and removed the old interface. After I tried starting with my new port and it’s not starting.

It says interface is not running with that port. Can you please let me know whether there is any way to change my Newport as default port.

Is there any commands / changing configuration files will help on this?

Regards, krish

From their docs:

During the installation of webMethods Universal Messaging, you have the
option of creating a default instance (called “umserver” by default) for all the
components installed. If you need to create additional instances, this can be
done using the ninstancemanager command line tool, which can be found under
<Software_AG_directory> /UniversalMessaging/tools/InstanceManager/.

Hi Mahesh,

Thanks for your support. How are you?

I haven’t create new UM instance while installing as am doing side by side migration. Here the problem is I have deleted the default port and running the UM with new port. After restart UM interface is not running with the new port.
Here i want to auto enable the new interface port as a default port when ever I start the UM. So i need some commands to do this manually.


Hi Krishna, I am good. Hope you are doing well.

I am not aware of this particular scenario you are currently with. Maybe someone from PM team should comment.

Ok . Thanks Mahesh.

Let see if any one will respond.

Thanks, Krish


The best way to modify the interfaces in this case would be to can use the um tools. These tools can modify/add Interfaces while a realm is offline.

To do this run the umTools runner under tools/runner. This then has a number of tools to modify the interfaces on a realm:

  1. Recovery



Hi Stuart,

Thanks for your response.

You are correct, but do you have any specific commands to run the interface with specific port via UM tools.

I want to activate the disabled/non-default port via UM command line tools. Do you have any idea on this.

Thanks, Krish.