TWS + Office 2000 (using russian chars in URIs)


Can someone help me to solve a little problem. I failed to use russian characters in URIs of WebDAV resources.

My configuration:
Tamino WebDAV Server 4.1.1
MS Office 2000

As I read in readme.txt for TWS, Office 2000 uses platform encoding to transfer URIs and there is a slide parameter org.apache.slide.urlEncoding that can tune TWS to understand those URIs.

So I set this parameter to Windows-1251.

What happened:
PROPFIND /taminowebdavserver/ HTTP/1.1
Content-type: text/xml; charset=UTF-8
Host: mosntbk2:4000
Content-length: 100
Depth: 1

<?xml version="1.0"?>
<D:propfind xmlns:D=“DAV:”>



PROPFIND /taminowebdavserver/%C4%EE%EA%F3%EC%E5%ED%F2%E0%F6%E8%FF HTTP/1.1


Response is the same (just like request was made for the root collection). Do you have any idea what happened? TWS didn’t answer that the object was not found and at the same time gave wrong response…

Hello Alexander,

did you create the folder, while the server was using the Russian character set?

The most dirct way to talk to the WebDAV server is our basic client, as no additional conversions are made.

We will soon dig into this URL problem further.

Best regards


All folders and files were created with MS Office XP. Unlike MS Office 2000, XP version uses UTF-8 to send URIs to WebDAV server. So it looks OK and I can create and browse russian folders successfully (but only with Apache on top of TWS, otherwise I expirence similar problems). But here very few customers have migrated to Office XP, most of them still use Office 2000.

As I read in README.TXT file for TWS, I should change parameter org.apache.slide.urlEncoding to platform encoding. I did that but with troublesome circumstances.

1. When I try to change directory to one with russian letters, the its contents remain the same. The examples provided in my first post tell that TWS process russian URIs wrong. The tests have been performed with TWS Basic client.

2. Another problem is that names of russian folders are corrupted. Maybe office 2000 doesn’t like output in UTF-8 or something. By the way is it possible to switch TWS output to different encoding?

Now your question:
> did you create the folder,
> while the server was using the Russian
> character set?

Yes I tried that. But it worked fine until I pressed refresh button. After that folder name appeared corrupted (But in TWS metadata it looked fine).

I should also mention that all folders in my tests have correct encoding inside TWS. I checked that quering TWS metadata collection.

When I created this topic I thought that maybe I misunderstood or forgot something configuring TWS. If it seems to be a deeper problem maybe I’d better open a support request and provide a database backup for testing purposes?

Thank You!

Alexander Mikhin

Hello Alexander,

yes, please open a support request. I will post the results at this community after we know the reason for this behaviour.

Best regards


The only solution found is to migrate from Office 2000 to Office XP.

Office XP brings a new implementation of Web Folders (version 10) which uses UTF-8 instead of local encoding for URLs.

Maybe there are some other ways to upgrade Web Folders implementation. I tried to replace some DLLs manually and it seems to work well. However this trick is not documented and therefore a little perilous.