Trouble with flatfile:convertToString


I have a flatfile schema looking something like this:


Before I added a new field the convertToString service worked fine, generating something like:


When i added the field Discount to R the convertToString service behaves strangely. I receive the result:

H�012345�20050225�… (No error here)

Discount last on row, and all other fields empty!?
I’ve checked the original datastructure and it contains data in all appropriate fields, though not not in the same order as in the flatfile schema.

Anyone else seen this behaviour? and solved it?


Did you update the dictionary and schema, and delete and recreate the document?

If that’s not the solution, what is the error message?

It could be related to something corrected with one of the IS fixes for WmFlatFile (I believe there are quite a few).

Yes, i’ve updated the schema and regenerate the DT.

I don’t receive an error in the convertToString. I recieve the error much later and have traced it’s root to the odd behaviour of convertToString.

I have v6.1 of the flatfile package and no patches. Guess i’ll have a look for some patch.

Hi, Have you found the patch yet? I have encountered similar issue, but my situation is that, I did’t add new field to the schema/dictionary, there was no changes with the schema, and empty values were generated in our system testing environment.On our development environment, it works as expected. Even though I was able to work around this issue in syetem testing environment after I deleted and regenerated the document from the schema. But I still don’t understand why I need do that. Thanks for sharing your founding if any.

Even the same problem i have encountered with. Some the records were not seen once i run the convertToString step. So i am getting blank values in my report finally. I am using 6.0.1. If you have found any fixes for the same, pls let me know.


you should try IS_6-0-1_SP2_Fix103 (1-NNHKX).

Another option is to search Advantage for convertToString.