TN Default Delivery HTTP

Hi all,

We are using WM 6.1 with TN and are trying to deliver an EDI message using the TN default delivery service of HTTP.

We have configured the partner profile to use a service on our wM IS and the IS ip address(just as a test).
TN recognises the document and receiver successfully and according to the Transactional analysis logs TN delivers the document successfully (i.e. we get an HTTP 200 response).

However, the service that we specify to be executed doesn’t seem to execute. We have a debugLog entry and that doesn’t write anything to the server log file. The service that we call doesn’t have any inputs or outputs, but just a debug statement.

Can anyone tell me how we can check whether this is working correctly or not?

Thanks and regards

Hi Rax,

Try this once by using the savePipelineToFile and restorePipelineFromFile services. then you will know either it is working or not.

actually it has to show the debug log message in the server log file.


Hi Gannu,

Thanks for the reply.

Actually, I do have a save pipeline in the service and nothing has been saved to the server, and no debug log message is written.

That’s why I’m confused! :wink:


Can you post these items for us to review:

  • URL that is defined in the profile
  • Service that you’re trying to invoke
  • The logging level set in Administrator and the level of the debugLog call


Did you create a processing rule to invoke the service?Can you tell us where have you specified in TN to invoke the service.


Hi guys,

I’m working with Rax on this project.
Let me answer your questions and give you some more info.

We have a Processing Rule that, when a document Type, in this case an TRADACOMS Invoice, is sumited, it should be delivered by the receiver’s prefered method.
Now, the receiver trading partner, has a delivery method of primary http as prefered method
See the picture attached for details.
When the doc is submited to TN, in the Transaction Analysis, the doc is recognised and the delivered, according to TN.
This service has no inputs and just writes a message to the log, using debugLog service. I see nothing in the log.

This is really puzzling us. Any thought?


Did you select both deliver document by option and Execute a service option under the Actions tab of the Processing rule?


Hi Ramesh,

I did that before, and yes, it executed my service, but that’s not what I want to do.
I want to simulate the delivery to a normal service, inside my IS, just to prove that the document type deliveres the document.
In another phase, I wanted to savePipelineToFile, to check what kind of data TN uses when delivering the document. I did not make it passed phase 1. :frowning:

My next question is: Can TN deliver to a standard flow service? I would believe so, because what is the difference between this service and the


The job of a TN custom delivery service is to deliver the document using some custom logic. For example, I have used a custom delivery service in the past to wrap the document in a soap envelope, add a WS-Security token in the header and post it to the recipient.

You can certainly build a simple custom delivery service that does something like write the document to a file. Just make sure the flow or java service uses the delivery service specification as indicated in the TN User’s Guide.



In the Processing rule, select only Execute service option.In this service, add a custom attribute to the bizdoc and then reroute it to TN.Create one more Processing rule with the same selection criteria as the other processing rule and in the extended criteria, select the custom attribute and under the Actions tab, select the deliver document by option.In this way, you are invoking the service and as well as delivering the document to the Trading Partner.


Excuse me if my question is out of context of this thread. We have RosettaNet module set up with IS6.1. The customers submit their documents to wm.ip.rn:receive over https, the document is recognized in TN and an appropriate process model (built using Modeler) is kicked off. So far, so good. Now we have a document coming in from the partner (over https to wm.ip.rn:receive), for which we don’t have a process model set up (we don’t need one). All we wanna do when this document comes in, is to invoke a service. The problem is, when I (on behalf of a customer - as a test) post this document to wm.ip.rn:receive, it shows up in TN alright (document type, sender, receiver identified properly), but, the service (set up in the processing rule to be invoked sych) does not kick off. After I failed a few times to invoke the service, I decided to post the same document using and voila… the document was identified and service was invoked - which confirms that processing rule is setup right.

What I wanna ask is - how is wm.ip.rn:receive different from and why does a post to the former does not invoke the processing rule whereas the later one does. I’m also wondering (surprisingly for the first time, after having worked on it for a few months already) on what the bridge is between rn:receive to tn:receive, ie how does a doc sent to rn:receive show up in TN?

Thanks, Rohit


How are you invoking the Process Model? Are you publishing a doc to the broker to invoke the process model or using an arrival of an external document as an input to the process model?If you are using the latter one, then no matter what, as the document type arrives in TN, the flow service will not be invoked identified in the Execute the service field of the processing rule.Try out this, disable the process model and send the doc to TN, this should invoke the service specified in the Execute Service field.
Let us know the results.




I don’t think we are on the same page of the problem that I stated. As I said in my first post - We do NOT have a Process Model set up for the document in question, so there is no disabling the model (there is none to start with). I also mentioned in my first post that I have confirmed that posting the document to TN does invoke the processing rule and my service, BUT, the document is not posted to TN directly (tn:receive), instead, it comes to rn:receive (RosettaNet receive).

It is not I who will post the document, it will come from a Trading Partner, as a part of TP’s process that is setup using RosettaNet (which is why the document comes to rn:receive and not to tn:receive). And yes, even when the document is sent to rn:receive, it shows up in the TN console fine, ie, is identified properly - senderID, receiverID, documentType, etc. Im wondering why it still doesn’t invoke the processing rule. Besides, how does a document that gets sent to rn:receive is forwarded to TN?

Thanks, Rohit


In the TN Activity log what is showing in the Task section or tell what steps are you seeing there…When you double click on the xml document in TAnalysis screen,see Activitylog tab.